Bug 731605 - aeulus-image build fails to build RHEL 6.x images when using separate boot.iso
Summary: aeulus-image build fails to build RHEL 6.x images when using separate boot.iso
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 1.0.0
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
Assignee: Ian McLeod
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 02:08 UTC by Marcelo Giles
Modified: 2018-11-28 21:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:10:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0588 normal SHIPPED_LIVE new packages: imagefactory 2012-05-15 22:31:27 UTC

Description Marcelo Giles 2011-08-18 02:08:51 UTC
Description of problem:

When creating a RHEL-6 image with aeolus-image build --provider (rhevm or ec2) --template rhel61.xml, the build process fails if you use a) original RHEL 6.1 install dvd iso or b) expanded installation tree. 

Apparently, the module that handles the RHEL-6 installations tries to access url://rhel-server-6-x86_64/images/boot.iso.

But this file is no longer shipped in the RHEL 6 installation dvd isos but is distributed on a separate iso (this is a 250 MB file now).

ls ../images/ 
efiboot.img  efidisk.img  install.img  product.img  pxeboot  README  TRANS.TBL

cat ../images/README
The boot.iso file that is sometimes found in the images directory has
been removed for space reasons.  It is available as a separate download
from RHN.  boot.iso is an ISO 9660 image of a bootable CD-ROM.  It is useful
in cases where the CD-ROM installation method is not desired, but the
CD-ROM's boot speed would be an advantage.

This works, however, if you create an installation tree and manually add the boot.iso image under ../images.

Examples of templates used:

ISO image:

<template>
  <name>rhel6_1_x86_64</name>
  <os>
    <name>RHEL-6</name>
    <version>1</version>
    <arch>x86_64</arch>
    <install type='iso'>
      <iso>http://FQDN/rhel6.1/Server/x86_64/rhel-server-6.1-x86_64-dvd.iso</iso>
    </install>
  </os>
  <description>rhel 6.1 template</description>
</template>

Install tree:

<template>
  <name>rhel6_1_x86_64</name>
  <os>
    <name>RHEL-6</name>
    <version>1</version>
    <arch>x86_64</arch>
    <install type='url'>
      <url>http://FQDN/rhel6.1/Server/x86_64/</url>
    </install>
  </os>
  <description>rhel 6.1 template</description>
</template>

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:

  
Actual results:


Expected results:


Additional info:

Comment 1 Mike Orazi 2011-08-18 13:44:33 UTC
Ian -- I know we talked about this a day or so back, but I don't want to misquote you...


Do we need to expand the tdl to allow for this type of behavior, or do we need to document the tree layout that we need?

Comment 2 Chris Lalancette 2011-08-18 13:57:58 UTC
Both, really.  Though the second one is what we should do for beta customers in the short term.

Comment 5 wes hayutin 2011-09-28 16:41:47 UTC
making sure all the bugs are at the right version for future queries

Comment 7 jrd 2011-10-03 17:10:14 UTC
https://www.aeolusproject.org/redmine/issues/2445

Probably not for 1.0?

Comment 8 Chris Lalancette 2011-10-07 15:44:21 UTC
So this should, in theory, be fixed.  Oz 0.7.0 prefers to download images/pxelinux/vmlinuz and images/pxelinux/initrd.img from the source tree now.  If it finds those in place, then it downloads and boots from those.

By taking a quick look at a RHEL-6 ISO, it looks like those files are indeed in place.  So without actually testing it, this should work.  For now I'll put this on ON_QA so that QE can test to make sure this actually works.

Comment 9 Aziza Karol 2011-10-11 05:53:44 UTC
Building Rhel6.1 images using separate boot.iso is successful.
verified by using above templates.

build by ISO image:
imagefactory.log:

2011-10-11 01:39:49,366 DEBUG imgfac.qmfagent.ImageFactoryAgent.ImageFactoryAgent pid(5043) Message: Method called: name = build_image 
 args = {'image': '', 'build': '', 'template': "<template>\n  <name>rhel6_1_x86_64</name>\n  <os>\n    <name>RHEL-6</name>\n    <version>1</version>\n    <arch>x86_64</arch>\n    <install type='iso'>\n<iso>http://FQDN/rhel6.1/Server/x86_64/rhel-server-6.1-x86_64-dvd.iso</iso>\n    </install>\n  </os>\n  <description>rhel 6.1 template</description>\n</template>\n", 'targets': ['ec2']} 
 handle = <cqmf2.AgentEvent; proxy of <Swig Object of type 'qmf::AgentEvent *' at 0x2232270> > 
 addr = redhat.com:imagefactory:d5f9d22e-d9c7-4c1a-815e-6a9f729f3b33:image_factory 
 subtypes = {} 
 userId = anonymous
2011-10-11 01:39:49,366 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-10-11 01:39:49,393 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:39:49,403 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'object_type': 'image', 'uuid': '8240eda8-d632-4468-b85c-bb94f75f80bc'}) for http://localhost:9090/images/8240eda8-d632-4468-b85c-bb94f75f80bc
2011-10-11 01:39:49,486 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:39:49,489 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'image': '8240eda8-d632-4468-b85c-bb94f75f80bc', 'object_type': 'build', 'uuid': '2dd9999d-670f-4415-9c58-8a05c992918a'}) for http://localhost:9090/builds/2dd9999d-670f-4415-9c58-8a05c992918a
2011-10-11 01:39:49,613 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-10-11 01:39:49,614 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Found neither a call-time config nor a config file - doing nothing
2011-10-11 01:39:49,615 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Building Linux for non-upload cloud (ec2)
2011-10-11 01:39:49,616 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Storing placeholder object for non upload cloud image
2011-10-11 01:39:49,618 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:39:49,621 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'object_type': 'template', 'uuid': 'a293ed0a-89f2-4f20-a043-ec5750d954d1'}) for http://localhost:9090/templates/a293ed0a-89f2-4f20-a043-ec5750d954d1
2011-10-11 01:39:49,704 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:39:49,705 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:39:49,705 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:39:49,706 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:39:49,706 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:39:49,707 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:39:49,707 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:39:49,707 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'icicle': 'none', 'uuid': 'a7e138d9-caa9-43f8-9342-d7f203446cc0', 'template': 'a293ed0a-89f2-4f20-a043-ec5750d954d1', 'target_parameters': None, 'object_type': 'target_image', 'target': 'ec2', 'build': '2dd9999d-670f-4415-9c58-8a05c992918a'}) for http://localhost:9090/target_images/a7e138d9-caa9-43f8-9342-d7f203446cc0
2011-10-11 01:39:49,955 DEBUG imgfac.BuildJob.BuildAdaptor pid(5043) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed percent complete from 0 to 100
2011-10-11 01:39:49,956 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Getting metadata (['latest_unpushed']) from http://localhost:9090/images/8240eda8-d632-4468-b85c-bb94f75f80bc
2011-10-11 01:39:49,959 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Getting metadata (['latest_build']) from http://localhost:9090/images/8240eda8-d632-4468-b85c-bb94f75f80bc
2011-10-11 01:39:49,962 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'latest_unpushed': '2dd9999d-670f-4415-9c58-8a05c992918a'}) for http://localhost:9090/images/8240eda8-d632-4468-b85c-bb94f75f80bc
2011-10-11 01:39:49,965 DEBUG imgfac.BuildJob.BuildAdaptor pid(5043) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed status from NEW to COMPLETED
2011-10-11 01:39:49,965 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Completed placeholder warehouse object for linux non-upload image...



build by Install tree:
imagefactory.log:
2011-10-11 01:43:14,640 DEBUG imgfac.qmfagent.ImageFactoryAgent.ImageFactoryAgent pid(5043) Message: Method called: name = build_image 
 args = {'image': '', 'build': '', 'template': "<template>\n  <name>rhel6_1_x86_64</name>\n  <os>\n    <name>RHEL-6</name>\n    <version>1</version>\n    <arch>x86_64</arch>\n    <install type='url'>\n      <url>http://FQDN/rhel6.1/Server/x86_64/</url>\n    </install>\n  </os>\n  <description>rhel 6.1 template</description>\n</template>\n", 'targets': ['ec2']} 
 handle = <cqmf2.AgentEvent; proxy of <Swig Object of type 'qmf::AgentEvent *' at 0x2232270> > 
 addr = redhat.com:imagefactory:d5f9d22e-d9c7-4c1a-815e-6a9f729f3b33:image_factory 
 subtypes = {} 
 userId = anonymous
2011-10-11 01:43:14,641 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-10-11 01:43:14,642 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:43:14,652 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'object_type': 'image', 'uuid': 'efde362f-a391-4c04-8ea8-2556d5884d4b'}) for http://localhost:9090/images/efde362f-a391-4c04-8ea8-2556d5884d4b
2011-10-11 01:43:14,736 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:43:14,738 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'image': 'efde362f-a391-4c04-8ea8-2556d5884d4b', 'object_type': 'build', 'uuid': 'aa47c7ce-29da-4d4a-bce9-f54935da9b4b'}) for http://localhost:9090/builds/aa47c7ce-29da-4d4a-bce9-f54935da9b4b
2011-10-11 01:43:14,862 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-10-11 01:43:14,863 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Found neither a call-time config nor a config file - doing nothing
2011-10-11 01:43:14,864 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Building Linux for non-upload cloud (ec2)
2011-10-11 01:43:14,864 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Storing placeholder object for non upload cloud image
2011-10-11 01:43:14,866 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:43:14,869 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'object_type': 'template', 'uuid': 'f3827fab-3dbf-4cea-8d54-702514842f60'}) for http://localhost:9090/templates/f3827fab-3dbf-4cea-8d54-702514842f60
2011-10-11 01:43:14,951 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:43:14,952 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:43:14,952 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:43:14,953 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:43:14,954 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:43:14,954 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:43:14,954 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:43:14,954 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'icicle': 'none', 'uuid': 'e8972021-eeba-48d5-961e-6d9d6d9a2bb3', 'template': 'f3827fab-3dbf-4cea-8d54-702514842f60', 'target_parameters': None, 'object_type': 'target_image', 'target': 'ec2', 'build': 'aa47c7ce-29da-4d4a-bce9-f54935da9b4b'}) for http://localhost:9090/target_images/e8972021-eeba-48d5-961e-6d9d6d9a2bb3
2011-10-11 01:43:15,203 DEBUG imgfac.BuildJob.BuildAdaptor pid(5043) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed percent complete from 0 to 100
2011-10-11 01:43:15,204 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Getting metadata (['latest_unpushed']) from http://localhost:9090/images/efde362f-a391-4c04-8ea8-2556d5884d4b
2011-10-11 01:43:15,205 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Getting metadata (['latest_build']) from http://localhost:9090/images/efde362f-a391-4c04-8ea8-2556d5884d4b
2011-10-11 01:43:15,209 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'latest_unpushed': 'aa47c7ce-29da-4d4a-bce9-f54935da9b4b'}) for http://localhost:9090/images/efde362f-a391-4c04-8ea8-2556d5884d4b
2011-10-11 01:43:15,211 DEBUG imgfac.BuildJob.BuildAdaptor pid(5043) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed status from NEW to COMPLETED
2011-10-11 01:43:15,212 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Completed placeholder warehouse object for linux non-upload image...


verified on:
[root@dell-pe1950-02 rheltempwes]# rpm -qa |egrep 'conductor|iwhd|imagefactory|oz' 
aeolus-conductor-0.5.0-0.20111007200330gite77b251.el6.noarch
imagefactory-jeosconf-ec2-rhel-0.1.0-1.el6.noarch
aeolus-conductor-doc-0.5.0-0.20111007200330gite77b251.el6.noarch
imagefactory-jeosconf-ec2-fedora-0.1.0-1.el6.noarch
iwhd-0.98.15.z3-2.el6.x86_64
rubygem-imagefactory-console-0.5.0-4.20110824113238gitd9debef.el6.noarch
oz-0.7.0-3.el6.noarch
aeolus-conductor-daemons-0.5.0-0.20111007200330gite77b251.el6.noarch
imagefactory-0.7.0-1.el6.noarch

Comment 11 errata-xmlrpc 2012-05-15 20:10:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0588.html


Note You need to log in before you can comment on or make changes to this bug.