Bug 731611 - udp test is missing in network.py
Summary: udp test is missing in network.py
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Guangze Bai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 03:06 UTC by Caspar Zhang
Modified: 2015-02-08 21:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A regression was introduced since v7 1.1 that udp test was missing in v7 network test, this issue has been fixed in v7 1.4, now udp test will be executed when running v7 network test.
Clone Of:
Environment:
Last Closed: 2011-11-08 15:44:18 UTC


Attachments (Terms of Use)
network test patch adding lmbench udp latency test back in. (611 bytes, patch)
2011-09-29 15:01 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1436 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-11-08 23:28:41 UTC

Description Caspar Zhang 2011-08-18 03:06:42 UTC
Description of problem:

This issue was found in code review. I found dupTest() was not executed since 1.1. Is this intended, or an accident?

The issue was caused by SVN commit R411:

+    def run(self):
+
+        if not self.runSubTest(self.prepareForRun, "Setup", "prepare for network testing"):
+            return FAILED
+
+        if not self.runSubTest(self.configureInterfaces, "Interface Configuration"):
+            return FAILED
+
+        if not self.runSubTest(self.printInfo, "Info"):
             return FAILED
-
-        self.printInfo()

         # start testing
-        returnValue = self.tcpTest()
-        if returnValue == PASSED:
-            returnValue = self.udpTest()
-        if returnValue == PASSED:
-            returnValue = self.nfsTest()
-        if  returnValue== PASSED:
-            returnValue = self.icmpTest()
-
+        success = True
+        if not self.runSubTest(self.tcpTest, "TCP", "tcp latency and bandwidth test via lmbench"):
+            success = False
+        if not self.runSubTest(self.nfsTest, "NFS", "NFS file transfer test"):
+            success = False
+        if not self.runSubTest(self.icmpTest, "ICMP"):
+            success = False


Version-Release number of selected component (if applicable):
1.4 R16

Comment 1 Greg Nichols 2011-09-29 15:01:00 UTC
Created attachment 525588 [details]
network test patch adding lmbench udp latency test back in.

Comment 4 Caspar Zhang 2011-10-21 14:10:53 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
A regression was introduced since v7 1.1 that udp test was missing in v7 network test, this issue has been fixed in v7 1.4, now udp test will be executed when running v7 network test.

Comment 6 errata-xmlrpc 2011-11-08 15:44:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html

Comment 7 errata-xmlrpc 2011-11-08 18:32:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html


Note You need to log in before you can comment on or make changes to this bug.