Bug 731635 - fail to umount with endless rpc messge
Summary: fail to umount with endless rpc messge
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 07:23 UTC by Jian Li
Modified: 2014-03-04 00:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-18 12:36:19 UTC


Attachments (Terms of Use)
cyclic RPC debug message (4.71 KB, text/plain)
2011-08-18 07:25 UTC, Jian Li
no flags Details

Description Jian Li 2011-08-18 07:23:05 UTC
Description of problem:
I want to test export option 'hide', so ,I create /etc/exports:

====
/tmp *(rw,no_root_squash,hide)
/tmp/test *(rw,no_root_squash)
/etc *(rw,no_root_squash)
====

Then, mount shared directories,
#mount -o vers=4 localhost:/etc /tmp/test
#mount -o vers=4 localhost:/tmp /mnt/test

Then , check that 'hide' work fine, and umount
#umount /mnt/test
#umount /mnt/test  <=== error

[root@ibm-ls22-01 ~]# umount /tmp/test
umount.nfs: /tmp/test: device is busy
umount.nfs: /tmp/test: device is busy
[root@ibm-ls22-01 ~]# service nfs stop
Shutting down NFS mountd: [  OK  ]
Shutting down NFS daemon: [  OK  ]
Shutting down NFS quotas: [  OK  ]
^C

And I open rpcdebug, find that RPC prints cyclic debug message.(attacked)


Version-Release number of selected component (if applicable):
2.6.32-188.el6.x86_64
nfs-utils-1.2.3-7.el6.x86_64

Comment 1 Jian Li 2011-08-18 07:25:31 UTC
Created attachment 518810 [details]
cyclic RPC debug message

Comment 2 Jian Li 2011-08-18 07:26:10 UTC
ops :    cyclic debug message.(attached)

Comment 4 Jian Li 2011-08-18 07:41:36 UTC
I have use 'hide' wrongly, this bug should have nothing with 'hide', it may be caused by config file in /etc.

Comment 5 Jian Li 2011-08-18 07:52:19 UTC
If I delete '/tmp/test *(rw,no_root_squash)', I could umount /tmp/test successfully. Maybe this is not a bug!

Comment 6 J. Bruce Fields 2011-08-18 12:36:19 UTC
Right, you're not expected to be able to unmount exported filesystems.

Also, it looks like you're trying to re-export nfs (by mounting an nfs filesystem at /tmp/test, and also exporting /tmp/test).  That's not expected to work either.


Note You need to log in before you can comment on or make changes to this bug.