Bug 731717 - AttributeError: 'YumBaseCli' object has no attribute '_depsolving_failed'
Summary: AttributeError: 'YumBaseCli' object has no attribute '_depsolving_failed'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 739479 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 13:01 UTC by Sandro Mani
Modified: 2014-01-21 23:19 UTC (History)
9 users (show)

Fixed In Version: yum-3.4.3-5.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-02 18:16:21 UTC


Attachments (Terms of Use)

Description Sandro Mani 2011-08-18 13:01:16 UTC
Description of problem:
I did a sudo yum update --skip-broken, and when yum started downloading filelists, the wlan connection dropped. After yum tried all mirrors, I got the backtrace:
[...]
Trying other mirror.
Error: failure: repodata/234f0847beb2f19dffa8e73124c51dfec0bfc59028d8a35a77c313d1ab978ca1-filelists.sqlite.bz2 from updates-testing: [Errno 256] No more mirrors to try.
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 203, in main
    if base._depsolving_failed:
AttributeError: 'YumBaseCli' object has no attribute '_depsolving_failed'

Version-Release number of selected component (if applicable):
yum-3.4.3-4.fc16.noarch

How reproducible:
Always

Comment 1 Richard W.M. Jones 2011-08-21 19:39:04 UTC
Strong typing FTW ...

Comment 2 Zdeněk Pavlas 2011-09-19 08:47:46 UTC
*** Bug 739479 has been marked as a duplicate of this bug. ***

Comment 3 Richard W.M. Jones 2011-09-26 07:25:18 UTC
No fix?  It's been over a month and it breaks a critical
part of F16.

Comment 4 Zdeněk Pavlas 2011-09-26 08:49:29 UTC
Has been fixed on Aug 18 2011 in commit 00fcc59b.

Comment 5 Richard W.M. Jones 2011-09-26 09:11:10 UTC
I've done the backport.

Comment 6 Fedora Update System 2011-09-26 09:18:56 UTC
yum-3.4.3-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yum-3.4.3-5.fc16

Comment 7 Fedora Update System 2011-09-26 16:48:47 UTC
Package yum-3.4.3-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/yum-3.4.3-5.fc16
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-10-02 18:16:15 UTC
yum-3.4.3-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.