Bug 731718 - random values when running delloem command on ppc, s390x
Summary: random values when running delloem command on ppc, s390x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipmitool
Version: 6.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Petr Sklenar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 13:05 UTC by Petr Sklenar
Modified: 2011-12-06 14:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 14:39:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1603 normal SHIPPED_LIVE ipmitool bug fix update 2011-12-06 00:51:12 UTC

Description Petr Sklenar 2011-08-18 13:05:05 UTC
Description of problem:
there are really random numbers when running delloem command on s390x

Version-Release number of selected component (if applicable):
ipmitool-1.8.11-11.el6.ppc64
only ppc arch
didnt try s390x

i386 + x8664 works as expected

How reproducible:
deterministic


Steps to Reproduce:
# rpm -q ipmitool
ipmitool-1.8.11-11.el6.ppc64
# ipmitool -y 0000000000000000 -H 1.3.4.2 -U root -P XXXXXX delloem powermonitor

Actual results:

Power Tracking Statistics
Statistic      : Cumulative Energy Consumption
Start Time     : Tue Jul 14 22:55:10 2071
Finish Time    : Thu Oct 31 18:37:02 1991
Reading        : 3640655.9 kWh

Statistic      : System Peak Power
Start Time     : Thu May 10 15:42:06 2085
Peak Time      : Mon Jun 20 10:02:54 2061
Peak Reading   : 42496 W

Statistic      : System Peak Amperage
Start Time     : Thu May 10 15:42:06 2085
Peak Time      : Fri Sep 15 12:25:50 2023
Peak Reading   : 204.8 A


Expected results:

same as fro x8664:
# rpm -q ipmitool
ipmitool-1.8.11-11.el6.x86_64

# ipmitool -y 0000000000000000 -H 1.3.4.2 -U root -P XXXXXX delloem powermonitor
Power Tracking Statistics
Statistic      : Cumulative Energy Consumption
Start Time     : Thu Aug 18 11:47:10 2011
Finish Time    : Thu Aug 18 13:14:34 2011
Reading        : 0.2 kWh

Statistic      : System Peak Power
Start Time     : Thu Aug 18 11:47:36 2011
Peak Time      : Thu Aug 18 12:59:24 2011
Peak Reading   : 166 W

Statistic      : System Peak Amperage
Start Time     : Thu Aug 18 11:47:36 2011
Peak Time      : Thu Aug 18 12:24:05 2011
Peak Reading   : 0.8 A

Comment 3 Jan Safranek 2011-08-18 15:00:52 UTC
'ipmitool delloem powermonitor' does not convert integers from network format (it's little endian in IPMI!) to native one -> problems on non-Intel platforms.

Comment 4 RHEL Product and Program Management 2011-08-19 12:09:59 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 8 errata-xmlrpc 2011-12-06 14:39:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1603.html


Note You need to log in before you can comment on or make changes to this bug.