Bug 731723 - Audit system updates for 6.2
Audit system updates for 6.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: audit (Show other bugs)
6.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steve Grubb
Ondrej Moriš
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-18 09:32 EDT by Steve Grubb
Modified: 2011-12-06 13:20 EST (History)
3 users (show)

See Also:
Fixed In Version: audit-2.1.3-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 13:20:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2011-08-18 09:32:21 EDT
Description of problem:
There are a number of items fixed in upstream audit code that would be beneficial to pull in. The following is a list of relevant changes:

- Fix parsing of EXECVE records to not escape argc field
- If auditd's disk is full, send the right reason to client (#715315)
- Update linker flags for better relro support
- Make default size of logs bigger (#727310)
- Disable 2 kerberos config options in audisp-remote.conf
- In auditd, cleanup DAEMON_ACCEPT and DAEMON_CLOSE addr fields
- In ausearch/report, parse addr field of DAEMON_ACCEPT & DAEMON_CLOSE records
- If auditd shutsdown due to failed tcp init, write a DAEMON_ABORT event
- Parse and interpret NETFILTER_PKT events correctly
- Return error if auditctl -l fails (#709345)
- When ausearch is interpretting, output "as is" if no = is found
- Fix autrace to use correct syscalls on s390 and s390x systems
- Correct autrace rule for 32 bits systems
Comment 7 errata-xmlrpc 2011-12-06 13:20:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1739.html

Note You need to log in before you can comment on or make changes to this bug.