Bug 731919 - Empathy fails to connect with "Error contacting the Account Manager"
Summary: Empathy fails to connect with "Error contacting the Account Manager"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: empathy
Version: 15
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 05:01 UTC by Nick Fenwick
Modified: 2012-08-07 15:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 15:06:34 UTC


Attachments (Terms of Use)
Error dialog shown by Empathy after 20-30 second pause (21.70 KB, image/png)
2011-08-19 05:01 UTC, Nick Fenwick
no flags Details

Description Nick Fenwick 2011-08-19 05:01:03 UTC
Created attachment 518973 [details]
Error dialog shown by Empathy after 20-30 second pause

Description of problem:

Every time I start Empathy, either from a fresh boot or after coming out of suspend, it renders the main app mostly empty, there is a 20 or 30 second pause, then a dialog pops up, see attached png.

Version-Release number of selected component (if applicable):

I'll just list some rpm packages I have installed, not sure what's relevant.

empathy-3.0.2-3.fc15.i686
$ rpm -qa | grep telepathy
telepathy-filesystem-0.0.2-2.fc15.noarch
telepathy-butterfly-0.5.15-3.fc15.noarch
telepathy-gabble-0.12.2-1.fc15.i686
telepathy-mission-control-5.7.11-1.fc15.i686
telepathy-idle-0.1.9-1.fc15.i686
python-telepathy-0.15.19-3.fc15.noarch
telepathy-haze-0.5.0-1.fc15.i686
telepathy-glib-0.14.9-1.fc15.i686
telepathy-logger-0.2.8-1.fc15.i686
telepathy-salut-0.4.0-2.fc15.i686
telepathy-farsight-0.0.16-3.fc15.i686

How reproducible:

Every time.

Steps to Reproduce:
1. Run Empathy
2. Enjoy
  
Actual results:

I get the error dialog, click OK, empathy sits there without a connection.

Expected results:

Empathy should connect to my MSN account, as it did a month or two ago.

Additional info:

This used to work fine.

I run selinux in Permissive mode.  Selinux has been little more than a constant pain in my side, always getting in the way of httpd, java, mysql, and other core parts of my day.

I've found this error message on a couple of other bugs, e.g. https://bugzilla.redhat.com/show_bug.cgi?id=699157 and https://bugzilla.redhat.com/show_bug.cgi?id=698884, but the fix always seems to be related to selinux, and my selinux version is greater than the ones being talked about in those reports.

I tried a downgrade today just for the hell of it:
Aug 19 10:23:44 Installed: selinux-policy-3.9.16-23.fc15.noarch
Aug 19 10:23:55 Installed: selinux-policy-targeted-3.9.16-23.fc15.noarch

Still doesn't work.

I've tried running wireshark while starting Empathy but I see no network traffic of note during the attempt to contact out.

I run with firewall disabled, due to ports being blocked relating to trouble getting selinux policies to work some time ago and having not enabled it again since.

I've tried killing all empathy, telepathy, mission-control processes with kill -9 and running empathy from the command line, I get:

[neek]$ empathy

(empathy:5194): folks-WARNING **: Error preparing Backend 'telepathy': Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Comment 1 Fedora End Of Life 2012-08-07 15:06:38 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.