Bug 73196 - Resizing windows from the top right or top left does not work. Top center barely.
Summary: Resizing windows from the top right or top left does not work. Top center bar...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-31 18:12 UTC by Shane R. Stixrud
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 22:21:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shane R. Stixrud 2002-08-31 18:12:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
When moving my cursor over the top left or top right corner of a window my
cursor does not change into a resize icon at all.  To make matters worse moving
the cursor up the window to the top of the window sometimes changes the cursor
but the area of effect is WAY to touchy, I also noticed that moving the mouse
down from the root window to the top line of a window does not change the cursor
to resize.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Move cursor to top left corner of a window
2.Move cursor to top right corner of a window
3.Move cursor from root window to the top of a window
4.move cursor from within a window to the top line

Actual Results:  1. Isn't resizeable.
2. Isn't resizeable
3. Isn't resizeable
4. Resizeable but area of effect is too low.

Expected Results:  To be able to resize easily from these positions.

Additional info:

Comment 1 Havoc Pennington 2002-09-02 21:37:32 UTC
Which metacity version? recent ones expanded the top edge a bit.

Our default theme doesn't really leave a corner for top left/right though (other
than on the bottom of the titlebar).

You can alt-middleclick also.

Comment 2 Shane R. Stixrud 2002-09-03 21:02:12 UTC
After updating to up2date current the top edge is much better.  Why no top 
left/right?

Comment 3 Havoc Pennington 2002-09-03 22:18:40 UTC
because the buttons in Bluecurve go all the way into the corner.

Comment 4 Havoc Pennington 2003-01-12 22:21:32 UTC
The top edge is larger now, and I think the lack of corners on Bluecurve is 
deliberate.


Note You need to log in before you can comment on or make changes to this bug.