Bug 731975 - Org deletion should also update the Organization list on left pane of UI
Summary: Org deletion should also update the Organization list on left pane of UI
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Katello
Classification: Retired
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Jason E. Rist
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 10:25 UTC by Sachin Ghai
Modified: 2013-02-27 04:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-24 19:16:55 UTC


Attachments (Terms of Use)

Description Sachin Ghai 2011-08-19 10:25:45 UTC
Description of problem:
I removed an organization from webUI. Org was deleted successfully. However org name was still listed under "organization list" on left pane of UI.

Note: After deleting the org, when you navigate the other tab on UI, then the deleted org name is disappeared from the organization list.


Version-Release number of selected component (if applicable):
[root@dhcp201-207 katello]# rpm -qa | grep katello
katello-cli-0.1.4-1.git.63.54683c2.fc15.noarch
katello-0.1.64-1.git.0.0b431ff.fc15.noarch


How reproducible:
always

Steps to Reproduce:
1. Create a new org
2. Remove the org from right pane
3. Org was deleted but name was still there on left pane.



  
Actual results:
 Org name appears under "organization list" on left pane of UI even after deleting that org. And If u click on that deleted org name, an Error appeared:

> There was an error retrieving that row: Bad Request

Expected results:
Organization list should automatically be updated after deletion of an org

Additional info:

Comment 1 Jason E. Rist 2011-08-24 19:12:56 UTC
This works for me in FF 3.6, FF4, Chrome, and Opera.  What browser are you using?

Comment 2 Sachin Ghai 2011-08-25 06:28:26 UTC
I'm using FF3.6. 

Today, I tested this on following katello build and issue has now been fixed.

katello-0.1.70-1.git.7.ca8d03c.fc15.noarch


Note You need to log in before you can comment on or make changes to this bug.