Bug 731977 - memory leak: 25,830 bytes in 315 blocks are definitely lost
Summary: memory leak: 25,830 bytes in 315 blocks are definitely lost
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipmitool
Version: 6.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 10:33 UTC by Petr Sklenar ⛄
Modified: 2011-12-06 14:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 14:39:49 UTC


Attachments (Terms of Use)
memory leak (64.51 KB, text/plain)
2011-08-19 10:34 UTC, Petr Sklenar ⛄
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1603 normal SHIPPED_LIVE ipmitool bug fix update 2011-12-06 00:51:12 UTC

Description Petr Sklenar ⛄ 2011-08-19 10:33:19 UTC
Description of problem:
memory leak: 25,830 bytes in 315 blocks are definitely lost

Version-Release number of selected component (if applicable):
ipmitool-1.8.11-11.el6.i686

How reproducible:
deterministic

Steps to Reproduce:
1. valgrind --leak-check=full --log-file=valgrind.log ipmitool -I lanplus -H <> -U USERID -P PASSW0RD sol activate
2.# generate some traffic on the serial console on the PowerEdge machine (e.g. cat /var/log/messages; dmesg; while true; do yes; done; ...)
# kill (gently, with sigint or sigterm) the ipmitool
3. check valgrind.log
  
Actual results:
==14834== LEAK SUMMARY:
==14834==    definitely lost: 27,852 bytes in 339 blocks
==14834==    indirectly lost: 0 bytes in 0 blocks
==14834==      possibly lost: 0 bytes in 0 blocks
==14834==    still reachable: 452 bytes in 8 blocks
==14834==         suppressed: 0 bytes in 0 blocks
==14834== Reachable blocks (those to which a pointer was found) are not shown.
==14834== To see them, rerun with: --leak-check=full --show-reachable=yes
==14834== 
==14834== For counts of detected and suppressed errors, rerun with: -v
==14834== Use --track-origins=yes to see where uninitialised values come from
==14834== ERROR SUMMARY: 1166606 errors from 124 contexts (suppressed: 37 from 10)


Expected results:
no memory leak

Additional info:

Comment 1 Petr Sklenar ⛄ 2011-08-19 10:34:24 UTC
Created attachment 519005 [details]
memory leak

see the whole valgrind output

Comment 3 Jan Safranek 2011-08-19 10:58:37 UTC
Looks like bug #576004, fixed in RHEL 5.6.

Comment 4 RHEL Product and Program Management 2011-08-19 12:09:55 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 8 errata-xmlrpc 2011-12-06 14:39:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1603.html


Note You need to log in before you can comment on or make changes to this bug.