Bug 731986 - bkr workflow-simple --family doesn't pick latest distro for RHEL4
Summary: bkr workflow-simple --family doesn't pick latest distro for RHEL4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: inventory
Version: 0.6
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ---
Assignee: Dan Callaghan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 11:37 UTC by Branislav Náter
Modified: 2011-08-19 13:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-19 13:00:21 UTC


Attachments (Terms of Use)

Description Branislav Náter 2011-08-19 11:37:06 UTC
Description of problem:
workflow-simple --family parameter doesn't pick latest distro for RHEL4

How reproducible:
always

Steps to Reproduce:
1. bkr workflow-simple --arch=x86_64 --family=RedHatEnterpriseLinux4 --task=/CoreOS/procps/Regression/sysctl/bz697935-RFE-Restore-support-for-partial-sysctl-keys
  
Actual results:
distro picked for installation is RHEL4-U8_nfs-ES-x86_64

Expected results:
distro picked for installation is RHEL4-U9*

Comment 1 Bill Peck 2011-08-19 13:00:21 UTC
Looks like RHEL4-U9 wasn't tagged with STABLE and the simple workflow automatically adds that tag if you don't specify the exact distro.

Fixed the tags and it picks up the latest now.

Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.