Bug 732018 - openvpn-auth-ldap depends on old libobjc
Summary: openvpn-auth-ldap depends on old libobjc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openvpn-auth-ldap
Version: 15
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 13:39 UTC by Edgar Hoch
Modified: 2011-08-31 01:36 UTC (History)
1 user (show)

Fixed In Version: openvpn-auth-ldap-2.0.3-8.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 01:36:28 UTC


Attachments (Terms of Use)

Description Edgar Hoch 2011-08-19 13:39:45 UTC
Description of problem:

openvpn-auth-ldap on Fedora 15 is still the package from Fedora 12.
But Fedora 15 has a newer version of libojbc (libobjc.so.3 instead of libobjc.so.2) so installation fails.

# yum install openvpn-auth-ldap
[...]
Setting up Install Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package openvpn-auth-ldap.x86_64 0:2.0.3-6.fc12 will be installed
--> Processing Dependency: libobjc.so.2()(64bit) for package: openvpn-auth-ldap-2.0.3-6.fc12.x86_64
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    openvpn-auth-ldap-2.0.3-6.fc12.x86_64 from fedora


I guess that rebuilding the package openvpn-auth-ldap in the context of Fedora 15 will resolve the problem.


Version-Release number of selected component (if applicable):
openvpn-auth-ldap-2.0.3-6.fc12.x86_64
libobjc-4.6.0-10.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install openvpn-auth-ldap
  
Actual results:
Package openvpn-auth-ldap installation failes because of dependency problems.

Expected results:
Package openvpn-auth-ldap will be installed.

Comment 1 Matthias Saou 2011-08-21 09:33:47 UTC
Thanks for the report. I failed to remember the package was also broken in F-15 when I pushed the recent F-16 rebuild. The package had failed to build for a while for what I thought were obscure reasons... it turned out that all it needed was the --with-objc-runtime=GNU configure option to stop trying some Apple specific stuff.

Comment 2 Fedora Update System 2011-08-21 11:34:20 UTC
openvpn-auth-ldap-2.0.3-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/openvpn-auth-ldap-2.0.3-8.fc15

Comment 3 Fedora Update System 2011-08-23 04:30:55 UTC
Package openvpn-auth-ldap-2.0.3-8.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openvpn-auth-ldap-2.0.3-8.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openvpn-auth-ldap-2.0.3-8.fc15
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-08-31 01:36:24 UTC
openvpn-auth-ldap-2.0.3-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.