Bug 73212 - Segmentation fault on invocation
Segmentation fault on invocation
Status: CLOSED DUPLICATE of bug 65595
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-31 16:46 EDT by Michal Jaegermann
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-08-31 16:46:46 EDT
Description of Problem:

$ man -- /usr/share/man/man1/man.1.gz
Segmentation fault

These kind of arguments are not described as valid for 'man'; still
a program should not segfault if used in an unexpected way.  Unfortunately
/usr/bin/lesspipe.sh does exactly that.

This problem is not limited to (null) but affects also earlier releases.
Comment 1 Philip Rowlands 2002-09-29 14:48:22 EDT
This looks like a duplicate of #65595.

BTW, man uses getopt_long(3) (nm -D /usr/bin/man), so "--" is a valid 
argument, even if not specifically mentioned in the documentation.
Comment 2 Miloslav Trmac 2004-03-08 14:38:18 EST

*** This bug has been marked as a duplicate of 65595 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.