Bug 732207 - Dracut 013-4.fc16 adds ~20 sec. delay before boot starts.
Summary: Dracut 013-4.fc16 adds ~20 sec. delay before boot starts.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 16
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-20 18:07 UTC by sd.domrep
Modified: 2011-08-24 08:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-24 08:09:17 UTC


Attachments (Terms of Use)

Description sd.domrep 2011-08-20 18:07:48 UTC
Description of problem:

Recently I opened the bug report #729538, I thought the kernel it self caused the 20 sec halt. But I updated dracut to dracut-013-1.fc16 and this problem disappeared, I realized that it was dracut.
So now I have this 20 sec delay before boot starts also with dracut-013-4.fc16.
I downgraded it to dracut-013-1.fc16 and now there is no any delay.

So, dracut-013-4.fc16 adds ~ 20 sec delay before my boot starts.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

You can find anything in the bug #729538

Comment 1 Harald Hoyer 2011-08-22 08:57:49 UTC
Can you give me "dmesg" from a boot with dracut-013-4 and dracut-013-1?

You will have to recreate the initramfs after installing the other dracut version with:

# dracut -f

Comment 2 Harald Hoyer 2011-08-22 09:00:14 UTC
Your dmesg logs show, that your initramfs was created with:

[    5.937923] dracut: dracut-011-15.git20110720

Comment 3 sd.domrep 2011-08-22 16:46:32 UTC
Yes, it was, all of those kernels in my bug 729538 was created with dracut-011-15.git20110720. But after that, I installed dracut-013-1.fc16, recreated initramfs and this removed 20 sec delay.

That is why now then I got this 20 sec delay again I specially downgraded dracut-013-4.fc16 to dracut-013-1.fc16 and created initramfs from the same kernel.
Please see small video I uploaded in bug 729538, may be it helps to find truth.

Thanks

Comment 4 Harald Hoyer 2011-08-23 06:17:34 UTC
can you give me dmesg logs with dracut-013-1.fc16 and dracut-013-4.fc16?

Comment 5 sd.domrep 2011-08-24 07:29:16 UTC
No, sorry, I can not right now. Because last update of the kernel and Xorg made fedora unusable:
1. USB flash auto-mount takes about 10-25 second
2. my old i915GM video card draws 2D very slow, when I do resize window with midnight commander I can see how this window redraws 3 or 4 time within 2-3 sec.
3. systemd can not stop iptables, it just hangs ALL laptop and I have to turn power off to reboot. Iptables rules is not loaded by default now.

So I decided to step aside and wait, because I start to notice that in fedora development one step forward needs two or three steps back.

And may be later those problems will disappear by them selfs, as it usually happen.

But now this bug should be closed.


Note You need to log in before you can comment on or make changes to this bug.