Bug 732212 - UI freezes when Migrate extents functionality is used
Summary: UI freezes when Migrate extents functionality is used
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-lvm
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Marek Grac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-20 20:47 UTC by Charlweed Hymerfan
Modified: 2012-05-10 08:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-10 08:49:38 UTC


Attachments (Terms of Use)

Description Charlweed Hymerfan 2011-08-20 20:47:30 UTC
Description of problem:
Attempting to migrate extends from physical volume on/dev/md127 to physical volume on /dev/md0
Both are two-disk software raid-1 volumes that are part of a single volume group.
No other options were selecten in the "Migrate extents" dialog, but the entire UI freezes when "OK" is clicked. Frozen means that it does not even repaint when another window covers a system-control-lvm window. Looks like a death or blockage of the event thread.

Version-Release number of selected component (if applicable):
Unknown, UI is frozen.

How reproducible:
Once, so far.

Steps to Reproduce:
1. Select physical extent
2. Click the "Migrate extents"  button
3. Click "Ok"
  
Actual results:
UI Fails to respond or repaint.

Expected results:
Progress dialog appears.

Additional info:
pmove is running, as shown by "ps xua":
/sbin/pvmove --config log{command_names=0} --alloc normal /dev/md126:0-76309

Comment 1 Charlweed Hymerfan 2011-08-20 21:00:24 UTC
This bug was sent while the UI was still hung. I will let it run no more than two hours.
Do'h! Logical volume was still mounted when I attempted to migrate extents.
Target raid physical volume is 1.2T in size, original is 320gb.
Target raid had not finished synhcronizing.
No obvious errors found by grepping /dev/log.
Logical volume has only one filesystem. No more then 43gb is in use on the entire filesystem, so it was 96% empty.

Comment 2 Charlweed Hymerfan 2011-08-22 01:42:23 UTC
It ran for 6 hours without updating the UI then completed successfully.
I logged off, launched the app again. The UI freezes on piratically all lengthy tasks.

Comment 3 Marek Grac 2012-05-10 08:49:38 UTC
You are right, UI waits until commands are finished. This is not a problem for lvdisplay, ... but lengthy tasks should be obviously handled in different way. This is surely valid request but s-c-lvm is going to be replaced by 

This feature is not critical and cannot cause data corruption, so it won't be fixed. System-config-lvm is obsolete tool and is being replaced by other tools.


Note You need to log in before you can comment on or make changes to this bug.