Bug 732220 - selinux-policy-targeted.noarch 0:3.9.16-38.fc15 libsemanage.semanage_reload_policy: load_policy returned error code 2
Summary: selinux-policy-targeted.noarch 0:3.9.16-38.fc15 libsemanage.semanage_reload_p...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-21 00:10 UTC by GoinEasy9
Modified: 2011-08-24 03:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-24 03:20:01 UTC


Attachments (Terms of Use)

Description GoinEasy9 2011-08-21 00:10:20 UTC
Description of problem:Error 2 when updating to selinux-policy-targeted.noarch 0:3.9.16-38.fc15


Version-Release number of selected component (if applicable):
selinux-policy-targeted.noarch 0:3.9.16-38.fc15

How reproducible: update or reinstall selinux-policy-targeted.noarch 0:3.9.16-38.fc15


Steps to Reproduce:
1.
2.
3.
  
Actual results:
selinux-policy-targeted-3.9.16-38.fc15.noarch.rpm  2.9 MB     00:02     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : selinux-policy-targeted-3.9.16-38.fc15.noarch 1/1 
libsemanage.semanage_reload_policy: load_policy returned error code 2.
libsemanage.semanage_install_active: Could not copy /etc/selinux/targeted/modules/active/policy.kern to /etc/selinux/targeted/policy/policy.24. (No such file or directory).
semodule:  Failed!

Installed:
  selinux-policy-targeted.noarch 0:3.9.16-38.fc15 


Expected results:


Additional info: load_policy returned error code 2, but, package was installed.
This laptop is runnning F15 KDE with updates-testing enabled.

Comment 1 GoinEasy9 2011-08-21 00:12:14 UTC
So far I'm not getting any AVC errors. I'm wondering if this error has reduced the functionality of selinux.

Comment 2 Miroslav Grepl 2011-08-22 11:40:25 UTC
Is there a policy.24 file in /etc/selinux/targeted/policy?


If you try to reinstall policy

# yum reinstall selinux-policy-targeted

are you still getting this?

Comment 3 GoinEasy9 2011-08-22 18:19:28 UTC
I originally tried "yum reinstall selinux-policy-targeted" and received the same error.  That's why I filed the bug.
Today, after reading your email, I tried again, and no error came up. There is a policy.24 in /etc/selinux/targeted/policy, and I'm still not receiving any AVC errors, so, I'll chalk this up to gremlins, unless subsequent errors appear.


Note You need to log in before you can comment on or make changes to this bug.