Bug 732293 - Cannot install tmux - missing dependency
Summary: Cannot install tmux - missing dependency
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: tmux
Version: el5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Sven Lankes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-21 17:43 UTC by Wayne Walker
Modified: 2011-08-22 21:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-22 21:25:29 UTC


Attachments (Terms of Use)

Description Wayne Walker 2011-08-21 17:43:41 UTC
Description of problem:
The version of tmux in EPEL depends on a version of libevent that is not available on CentOS 4 / RHEL 4

Version-Release number of selected component (if applicable):
tmux.x86_64 0:1.4-3.el5.1


How reproducible:
Always


Steps to Reproduce:
1. CentOS 5.4 - x86_64
2. Enable EPEL
3. yum install tmux
  
Actual results:

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package tmux.x86_64 0:1.4-3.el5.1 set to be updated
--> Processing Dependency: libevent-1.4.so.2()(64bit) for package: tmux
--> Finished Dependency Resolution
tmux-1.4-3.el5.1.x86_64 from epel has depsolving problems
  --> Missing Dependency: libevent-1.4.so.2()(64bit) is needed by package tmux-1.4-3.el5.1.x86_64 (epel)
Error: Missing Dependency: libevent-1.4.so.2()(64bit) is needed by package tmux-1.4-3.el5.1.x86_64 (epel)

# Note - libevent 1.1 is installed, from base.


Expected results:
libevent 1.4 and tmux1.4 would be installed


Additional info:

Comment 1 Wayne Walker 2011-08-22 21:25:29 UTC
I see now that the libevent-1.4 is available in 5.5 and 5.6 os repos.

For others with this problem, you probably have a bad repo file, mine, from RightScale, was hard coded to the 5.4 repo.

Wayne


Note You need to log in before you can comment on or make changes to this bug.