This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 732367 - Unable to turn on IM with ibus-gnome3
Unable to turn on IM with ibus-gnome3
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-22 03:39 EDT by Akira TAGOH
Modified: 2011-09-13 23:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 23:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2011-08-22 03:39:21 EDT
Description of problem:
Nothing happens with control+space nor Zenkaku_Hankaku on Japanese desktop if ibus-gnome3 is installed.

Version-Release number of selected component (if applicable):
$ rpm -qa ibus\*
ibus-pinyin-1.3.99.20110706-2.fc16.x86_64
ibus-chewing-1.3.9.2-3.fc16.x86_64
ibus-gtk3-1.3.99.20110419-17.fc16.x86_64
ibus-anthy-1.2.6-3.fc16.x86_64
ibus-gtk2-1.3.99.20110419-17.fc16.x86_64
ibus-m17n-1.3.2-10.fc16.x86_64
ibus-rawcode-1.3.1.20100707-4.fc15.x86_64
ibus-hangul-1.3.1-7.fc16.x86_64
ibus-libs-1.3.99.20110419-17.fc16.x86_64
ibus-1.3.99.20110419-17.fc16.x86_64
ibus-pinyin-db-android-1.3.99.20110706-2.fc16.noarch

How reproducible:
always

Steps to Reproduce:
1.boot f16alpha RC5
2.update packages and install ibus-gnome3
3.change the language and the keyboard layout to Japanese
4.relog into the desktop
5.press control+space or Zenkaku_Hankaku on gedit say
  
Actual results:
no change on the ibus indicator

Expected results:
should works as expected

Additional info:
just removing ibus-gnome3 works. and too many warnings is output when run ibus-daemon --xim -r --verbose:
(ibus-daemon:7338): IBUS-WARNING **: 03:36:32.677388: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [general/hotkey:use_bridge_hotkey] does not exist.

also from gnome-shell:
    JS ERROR: !!!   Exception was: TypeError: defaultLayout is null
    JS ERROR: !!!     lineNumber = '661'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/status/ibus/panel.js"'
    JS ERROR: !!!     stack = '"(true)@/usr/share/gnome-shell/js/ui/status/ibus/panel.js:661
([object _private_IBus_PanelService],"/org/freedesktop/IBus/InputContext_3")@/usr/share/gnome-shell/js/ui/status/ibus/panel.js:894
([object _private_IBus_PanelService],"/org/freedesktop/IBus/InputContext_3")@/usr/share/gjs-1.0/lang.js:110
"'
    JS ERROR: !!!     message = '"defaultLayout is null"'
Comment 1 fujiwara 2011-08-23 22:00:43 EDT
> [general/hotkey:use_bridge_hotkey] does not exist.

Thanks. I fixed this with revision 18.
I will integrate 18 soon since it includes some bug fixes.

>     JS ERROR: !!!   Exception was: TypeError: defaultLayout is null

I don't understand your problem.
Are you able to check where g-s failed?
Comment 2 fujiwara 2011-09-12 05:58:27 EDT
Do you still see this problem?
I fixed the first problem in the latest ibus.
Especially I don't understand the second problem.
Comment 3 Akira TAGOH 2011-09-13 08:01:43 EDT
How can I enable ibus-gnome3 on the latest gnome-shell btw? thought you said that on IRC one needs an extra step to enable the extension on it, but forgot the exact step to do it.
Comment 5 Akira TAGOH 2011-09-13 23:08:27 EDT
Thanks, that looks good to me.

gnome-shell-3.1.91-2.fc16.x86_64
ibus-1.3.99.20110817-5.fc16.x86_64
ibus-gnome3-1.3.99.20110817-5.fc16.x86_64

Note You need to log in before you can comment on or make changes to this bug.