Bug 732373 - Error: Failed to spawn applet viewer: Failed to execute child process "/usr/lib/jvm/java-1.6.0-openjdk.x86_64/
Summary: Error: Failed to spawn applet viewer: Failed to execute child process "/usr/l...
Keywords:
Status: CLOSED DUPLICATE of bug 731358
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: icedtea-web
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Deepak Bhole
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 08:22 UTC by Michal Nowak
Modified: 2013-03-08 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-23 14:41:03 UTC


Attachments (Terms of Use)

Description Michal Nowak 2011-08-22 08:22:52 UTC
Description of problem:

When on site with Java applet (e.g. mojebanka.cz) I get error msg: "icedteanp plugin error: Failed to run /usr/lib/jvm/java-1.6.0-openjdk.x86_64/jre/bin/java.  For more detail rerun "firefox -g" in a terminal window."

When firefox is executed with `-g', as suggested I get:

Detaching after fork from child process 5386.
/builddir/build/BUILD/icedtea-web-1.1.1/plugin/icedteanp/IcedTeaNPPlugin.cc:1500: thread 0x626840: Error: Failed to spawn applet viewer: Failed to execute child process "/usr/lib/jvm/java-1.6.0-openjdk.x86_64/jre/bin/java" (No such file or directory)

When accessed the site with applet.

Version-Release number of selected component (if applicable):

icedtea-web-1.1.1-1.el6.x86_64

How reproducible:

always

Comment 3 Deepak Bhole 2011-08-22 17:51:19 UTC
This sort of error shouldn't be occurring. IcedTea-Web has a dependency on java-1.6.0-openjdk. Can you run:

/usr/lib/jvm/java-1.6.0-openjdk.x86_64/jre/bin/java -version

And paste its output please?

Comment 4 Michal Nowak 2011-08-23 07:46:17 UTC
[newman@dhcp-25-35 ~]$ /usr/lib/jvm/java-1.6.0-openjdk.x86_64/jre/bin/java -version
bash: /usr/lib/jvm/java-1.6.0-openjdk.x86_64/jre/bin/java: No such file or directory

[newman@dhcp-25-35 ~]$ rpmquery java-1.6.0-openjdk
java-1.6.0-openjdk-1.6.0.0-1.40.1.10.3.el6.x86_64

[newman@dhcp-25-35 ~]$ rpmquery -l java-1.6.0-openjdk | grep "java$"
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java

Comment 5 Deepak Bhole 2011-08-23 14:41:03 UTC
Thanks. This is a dupe of 731358 then. Marking it as such.

*** This bug has been marked as a duplicate of bug 731358 ***


Note You need to log in before you can comment on or make changes to this bug.