Bug 732380 - TypeError: 'NoneType' object is not iterable (during iscsi discovery)
Summary: TypeError: 'NoneType' object is not iterable (during iscsi discovery)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ales Kozumplik
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:24aa39889433bc366789f4f3f51...
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-22 08:52 UTC by Ľuboš Kardoš
Modified: 2016-08-01 01:26 UTC (History)
2 users (show)

Fixed In Version: anaconda-13.21.135-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:41:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb-hnb18o (151.39 KB, text/plain)
2011-08-22 08:52 UTC, Ľuboš Kardoš
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-06 00:39:12 UTC

Description Ľuboš Kardoš 2011-08-22 08:52:28 UTC
abrt version: 2.0.5
executable:     /mnt/runtime/usr/bin/python
hashmarkername: anaconda
kernel:         2.6.32-191.el6.ppc64
product:        Red Hat Enterprise Linux
reason:         TypeError: 'NoneType' object is not iterable
time:           Mon Aug 22 08:51:30 2011
version:        6.2

anaconda-tb-hnb18o: Text file, 155020 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.132 exception report
:Traceback (most recent call first):
:  File "/usr/lib/anaconda/storage/iscsi.py", line 248, in discover
:    return [n for n in found_nodes if n not in self.nodes]
:  File "/usr/lib/anaconda/partIntfHelpers.py", line 465, in drive_iscsi_addition
:    found_nodes = anaconda.id.storage.iscsi.discover(**discovery_dict)
:  File "/usr/lib/anaconda/iw/advanced_storage.py", line 413, in addIscsiDrive
:    login_ok_nodes = pih.drive_iscsi_addition(anaconda, wizard)
:  File "/usr/lib/anaconda/iw/advanced_storage.py", line 479, in addDrive
:    rc = addIscsiDrive(anaconda)
:  File "/usr/lib/anaconda/iw/filter_gui.py", line 448, in _add_advanced_clicked
:    if not addDrive(self.anaconda):
:TypeError: 'NoneType' object is not iterable

Comment 1 Ľuboš Kardoš 2011-08-22 08:52:31 UTC
Created attachment 519244 [details]
File: anaconda-tb-hnb18o

Comment 2 Ľuboš Kardoš 2011-08-22 09:03:29 UTC
Start installation, advance to partitioning screen,
click Advanced storage configuration button,
select Add iSCSI target option and click Add drive button,
specify Target IP Address and click Add target button.
After these steps exception is occured.

Comment 3 Ľuboš Kardoš 2011-08-22 11:26:43 UTC
This happend when installed machine was not allowed initiator.

Comment 4 Ales Kozumplik 2011-08-22 11:34:24 UTC
(In reply to comment #3)
> This happend when installed machine was not allowed initiator.

What exactly do you mean that the installed machine was not an allowed initiator?

Comment 5 Ales Kozumplik 2011-08-22 12:23:41 UTC
Also can you please retest with the updates image at http://akozumpl.fedorapeople.org/bz732380.img ?

This wiki page explains how Anaconda update images are used:
http://fedoraproject.org/wiki/Anaconda/Updates

Comment 6 RHEL Product and Program Management 2011-08-22 15:10:30 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 7 Ľuboš Kardoš 2011-08-23 06:42:00 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > This happend when installed machine was not allowed initiator.
> 
> What exactly do you mean that the installed machine was not an allowed
> initiator?

I have two machines (machine1, machine2).
On machine1 I have executed these commands:

dd if=/dev/zero of=/tmp/iscsi-disk1 bs=1M count=4000
losetup /dev/loop0 /tmp/iscsi-disk1
tgtadm --lld iscsi --op new --mode target --tid=1 --targetname `hostname`:for.all
tgtadm --lld iscsi --op new --mode logicalunit --tid 1 --lun 1 -b /dev/loop0
dd if=/dev/zero of=/tmp/iscsi-disk1_2 bs=1M count=4000
losetup /dev/loop1 /tmp/iscsi-disk1_2
tgtadm --lld iscsi --op new --mode logicalunit --tid 1 --lun 2 -b /dev/loop1

On machine2 I have executed these steps:

Start installation, advance to partitioning screen,
click Advanced storage configuration button,
select Add iSCSI target option and click Add drive button,
specify machine1 IP Address and click Add target button.
After these steps exception is occured.

Comment 8 Ľuboš Kardoš 2011-08-23 06:58:10 UTC
(In reply to comment #5)
> Also can you please retest with the updates image at
> http://akozumpl.fedorapeople.org/bz732380.img ?
> 
> This wiki page explains how Anaconda update images are used:
> http://fedoraproject.org/wiki/Anaconda/Updates

When I test with that update it seems to be ok. After click 'Start discovery' message 'No new iSCSI nodes discovered' is showed.

Comment 9 Ales Kozumplik 2011-08-23 07:43:01 UTC
(In reply to comment #8)
> (In reply to comment #5)
> > Also can you please retest with the updates image at
> > http://akozumpl.fedorapeople.org/bz732380.img ?
> > 
> > This wiki page explains how Anaconda update images are used:
> > http://fedoraproject.org/wiki/Anaconda/Updates
> 
> When I test with that update it seems to be ok. After click 'Start discovery'
> message 'No new iSCSI nodes discovered' is showed.

Thanks for testing.

The patch has been pushed, 66eda3758fd57c9231740be25ae38f433ad8926b on rhel6-branch, 53b394a0031314bf2bbc7c8f9ed480369b0244ec on master.

Comment 11 Ľuboš Kardoš 2011-11-14 08:12:31 UTC
I reproduced with anaconda-13.21.117-1. Then I tested with anaconda-13.21.149-1 and it works. Moving to verified.

Comment 12 errata-xmlrpc 2011-12-06 10:41:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html


Note You need to log in before you can comment on or make changes to this bug.