Bug 73242 - 3 failed install attempts
Summary: 3 failed install attempts
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i586 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-01 16:03 UTC by John S. Caywood
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-01 16:06:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crashdump from second failed install (78.19 KB, application/octet-stream)
2002-09-01 16:06 UTC, John S. Caywood
no flags Details

Description John S. Caywood 2002-09-01 16:03:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.8 i86pc)

Description of problem:
1st installation attempt, anaconda crashed installing from CD#2
2nd attempt, media error on CD#2; I rebooted from CD#1 and ran
mediacheck on all 3 CDs -- no errors
3rd attempt anaconda again crashed while installing from CD#2
4th attempt successfully installed SuSE 7.3 to the very same system

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Expected Results:  If there was a media problem, I expected mediacheck to find
it, but
the media passed and anaconda still crashed again.

Additional info:

Pretty much plain vanilla PC: AMD K6-2/450, 128M RAM, 7.8G Samsung; SiS620 video
onboard, Davicom ethernet onboard, CMI sound onboard -- all worked fine during
install, and are working fine now under SuSE 7.3.  But I can't complete the
install of RedHat.
Disk partitioning was fine, tweaked with DiskDruid to 47M /boot, 6800M /, 256M
swap, 700M /home.  Software selection pretty much Workstation install, but not
emacs.
I have 2 anaconda crash dumps -- hope the bugzilla form lets me attache them.

Comment 1 John S. Caywood 2002-09-01 16:06:06 UTC
Created attachment 74425 [details]
anaconda crashdump from second failed install

Comment 2 Michael Fulbright 2002-09-02 15:11:31 UTC
There error messages (there are lots in the log you attached):

<4>hdb: irq timeout: status=0xd0 { Busy }
<4>hdb: ATAPI reset complete

indicate there were errors reading the CD. The mediacheck does not currently
accurately duplicate the accesses that occur during an install, and so sometimes
the mediacheck will pass but an install will fail.

Comment 3 John S. Caywood 2002-09-04 00:11:58 UTC
The root cause was that the IDE CDROM was primary slave -- too much data for the
controller to handle.  When msf@redhat.com showed me the irq error, I moved the
CDROM to secondary slave and the install completed successfully.

Thanks for the quick response.

As an enhancement, could anaconda be made more resilient in the face of
transient errors?


Note You need to log in before you can comment on or make changes to this bug.