Bug 732435 - /etc/sysconfig/irqbalance documentation is wrong
Summary: /etc/sysconfig/irqbalance documentation is wrong
Keywords:
Status: CLOSED DUPLICATE of bug 789946
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: irqbalance
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Petr Holasek
QA Contact: Petr Beňas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 13:11 UTC by Petr Beňas
Modified: 2016-10-04 04:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-27 01:58:11 UTC


Attachments (Terms of Use)
irqbalance.sysconfig patch (515 bytes, patch)
2011-08-22 17:00 UTC, Petr Holasek
no flags Details | Diff

Description Petr Beňas 2011-08-22 13:11:37 UTC
Description of problem:
/etc/sysconfig/irqbalance default comment says:
# IRQ_AFFINITY_MASK
#    64 bit bitmask which allows you to indicate which cpu's should
#    be skipped when reblancing irqs.  Cpu numbers which have their 
#    corresponding bits set to zero in this mask will not have any
#    irq's assigned to them on rebalance

but it actually works vice versa, CPUs with bits set to _one_ will not have any interrupts assigned to them.

Version-Release number of selected component (if applicable):
irqbalance-0.55-29.el6.x86_64

How reproducible:
always

Steps to Reproduce:
Set cpumask to irqbalance config file, restart the daemon and watch /proc/<PID>/smp_affinity files
  
Actual results:
CPUs with ones set in the mask does not have IRQs assigned, CPUs with zeros does.

Expected results:
Fixing the explaining comment seems better to me, lets have the settings in config file consistent with environment variable mask settings.


Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=617178#c20

Comment 2 RHEL Product and Program Management 2011-08-22 13:28:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Petr Holasek 2011-08-22 17:00:14 UTC
Created attachment 519317 [details]
irqbalance.sysconfig patch

Patch fixes description of the correct meaning of IRQ_AFFINITY_MASK variable 
in irqbalance's sysconfig file.

Comment 4 Petr Holasek 2012-04-27 01:58:11 UTC
Hi,

we are planning to rebase irqbalance to release 1.x in RHEL 6.4 where this change is already incorporated as it is, without any additional patches.

Petr H

*** This bug has been marked as a duplicate of bug 789946 ***


Note You need to log in before you can comment on or make changes to this bug.