Bug 732438 - radeon_rendercheck 114744 failures; with M86 (Mobility Radeon HD 3650) [1002:9591]
Summary: radeon_rendercheck 114744 failures; with M86 (Mobility Radeon HD 3650) [1002:...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 6.3
Hardware: i686
OS: Unspecified
low
low
Target Milestone: rc
: 6.3
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 13:32 UTC by Vitezslav Humpa
Modified: 2017-12-06 11:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 11:38:56 UTC


Attachments (Terms of Use)
Rendercheck log (453.95 KB, application/x-gzip)
2011-08-22 13:33 UTC, Vitezslav Humpa
no flags Details

Description Vitezslav Humpa 2011-08-22 13:32:56 UTC
Description of problem:
Running rendercheck:

$ rendercheck -t fill,dcoords,scoords,mcoords,tscoords,tmcoords,blend,composite -f a8r8g8b8,x8r8g8b8,a8

results in 2009494 tests passed of 2124238 total with 114744 failing

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.14.2-6.el6.i686

How reproducible:
Run the command above

Actual results:
See the log

Expected results:
All 2124238 tests pass

Additional info:
Rendercheck log is attached.
lspci -v:
VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3650 [1002:9591] (prog-if 00 [VGA controller])
	Subsystem: Toshiba America Info Systems Device [1179:ff62]
	Flags: bus master, fast devsel, latency 0, IRQ 30
	Memory at c0000000 (32-bit, prefetchable) [size=256M]
	I/O ports at 6000 [size=256]
	Memory at d6300000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at d6320000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: radeon
	Kernel modules: radeon

Comment 1 Vitezslav Humpa 2011-08-22 13:33:40 UTC
Created attachment 519280 [details]
Rendercheck log

Comment 2 Vitezslav Humpa 2011-09-23 15:27:52 UTC
Now also had 45800 failures on ATI R200 (Radeon 8500)

Comment 3 RHEL Product and Program Management 2011-10-07 16:13:29 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 4 Adam Jackson 2011-10-17 16:24:03 UTC
Result summary:

% grep error renderchecklog | awk '{ print $1 }' | sort | uniq -c | sort -n
   2240 DisjointOutReverse
   2240 DisjointXor
   2240 Xor
   4280 Atop
   8968 AtopReverse
   8968 DisjointAtopReverse
   8968 DisjointInReverse
   9000 DisjointDst
   9000 DisjointIn
   9000 DisjointOverReverse
   9000 DisjointSrc
   9000 Saturate
   9920 DisjointAtop
   9920 DisjointOver
  12000 Add

All of these are fairly rare ops, except for Add which is used in glyph accumulation.  However even that case happens only on offscreen pixmaps, whereas the test failures are all on windows.

Low impact, moving to 6.3.

Comment 5 Tomas Pelka 2011-11-02 12:52:46 UTC
I think this issue similarly as other rendercheck bugs are caused by running gnome-screensaver. I mean when g-s lock the screen during the test.

Without g-s it will PASS.

Comment 7 Suzanne Yeghiayan 2012-02-14 23:14:09 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 8 RHEL Product and Program Management 2013-10-14 05:14:51 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 9 Jan Kurik 2017-12-06 11:38:56 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.