Bug 732445 - Improve negotiator logging
Summary: Improve negotiator logging
Keywords:
Status: CLOSED DUPLICATE of bug 752157
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor
Version: 2.0
Hardware: All
OS: All
medium
medium
Target Milestone: 2.1.1
: ---
Assignee: Erik Erlandson
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 13:43 UTC by Jon Thomas
Modified: 2012-06-07 05:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-08 19:28:31 UTC


Attachments (Terms of Use)

Description Jon Thomas 2011-08-22 13:43:47 UTC
Opening this bz for improved negotiator logging. It's very difficult to troubleshoot usage problems with the current logs. I put together a tool to capture the useful information from the logs. The various endpoints of negotiation make it difficult to obtain statistics like usage for various groups. Much of what the tool does should be captured in the log. Here's a couple items I'd like to see:

1) the end of negotiation cycle should have a summary for each group that includes things like assigned quota, usage prior, usage after, type of rejection, some RR iteration stats, etc.

2) Definitive start and finish of negotiation. We have "BEGIN NEGOTIATION", but no "END NEGOTIATION" for each group. End negotiation should be accompanied by some stats regarding what occurred and current RR cycle. Where possible, every negotiator message between BEGIN and END should have a groupname header.

Comment 1 Jon Thomas 2011-08-24 21:09:19 UTC
3) Expand "no match found" to provide -better-analyze type of information.

Comment 2 Jon Thomas 2011-11-08 17:42:23 UTC
I think this can be closed as a dup of 721123, which was broken out into 4 bz's.

Comment 3 Matthew Farrellee 2011-11-08 19:28:31 UTC

*** This bug has been marked as a duplicate of bug 752157 ***


Note You need to log in before you can comment on or make changes to this bug.