Bug 732463 - v7 save command saves empty results
v7 save command saves empty results
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Petr Beňas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-22 10:36 EDT by Greg Nichols
Modified: 2015-01-04 18:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In v7 1.3, v7 save command would still run succeeded even if no test were executed before. This issue has been fixed in v7 1.4. Now v7 save command will give an error message indicating that no test has been exeuted yet and there is no test result to be saved.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-08 10:42:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to check for empty results before saving (488 bytes, patch)
2011-08-22 10:39 EDT, Greg Nichols
no flags Details | Diff
fix for pattern to match hostname from results filename (2.70 KB, patch)
2011-08-22 10:40 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2011-08-22 10:36:58 EDT
Description of problem:

The v7 save command will attempt to save current results when there are no test runs


Version-Release number of selected component (if applicable):

v7 1.4 R16


Steps to Reproduce:
1. v7 clean
2. v7 plan
3. v7 save
  
Actual results:

Saves empty results file


Expected results:

Should give error message.


Additional info:
Comment 1 Greg Nichols 2011-08-22 10:39:53 EDT
Created attachment 519301 [details]
patch to check for empty results before saving
Comment 2 Greg Nichols 2011-08-22 10:40:32 EDT
Created attachment 519302 [details]
fix for pattern to match hostname from results filename
Comment 6 Caspar Zhang 2011-10-21 12:48:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In v7 1.3, v7 save command would still run succeeded even if no test were executed before. This issue has been fixed in v7 1.4. Now v7 save command will give an error message indicating that no test has been exeuted yet and there is no test result to be saved.
Comment 9 Petr Beňas 2011-10-24 03:24:26 EDT
Reproduced in v7-1.4-16.el6.noarch and verified in v7-1.4-18.el6.noarch.
Comment 10 errata-xmlrpc 2011-11-08 10:42:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html
Comment 11 errata-xmlrpc 2011-11-08 13:32:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html

Note You need to log in before you can comment on or make changes to this bug.