Bug 73247 - userpasswd steals keyboard focus, but not window focus.
userpasswd steals keyboard focus, but not window focus.
Status: CLOSED DUPLICATE of bug 73748
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-09-01 13:45 EDT by Mike McLean
Modified: 2013-07-02 18:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2002-09-01 13:45:59 EDT
* usermode-gtk-1.60-1
* Milan-re0830.1

If you run userpasswd and change window focus, userpasswd keeps control of the
keyboard.  If userpassword gets obscured by another window, the user could
become very confused by the fact that they cannot type in the window that has
the focus.

userpasswd is even trapping keystrokes like alt-tab and ctl-alt-dn which are
used by the window manager and are not really sensible in a password.
Comment 1 Mike McLean 2004-05-17 17:17:53 EDT
This is still the case.  Is this a wontfix situation?
Comment 2 Jindrich Novy 2004-10-06 14:04:29 EDT

*** This bug has been marked as a duplicate of 73748 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.