Bug 732645 - Coverity scan revealed defects
Summary: Coverity scan revealed defects
Keywords:
Status: CLOSED DUPLICATE of bug 658971
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: David Teigland
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 07:57 UTC by Michal Luscon
Modified: 2011-09-19 15:29 UTC (History)
2 users (show)

Fixed In Version: sanlock-1.8-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 15:29:01 UTC


Attachments (Terms of Use)

Description Michal Luscon 2011-08-23 07:57:29 UTC
Description of problem:

1.
src/client_resource.c:123 - Comparing "opt_in" to null implies that "opt_in" might be null.
src/client_resource.c:173 - Passing null variable "opt_in->str" to function "send", which dereferences it.

2.
/src/client_resource.c:649 - Dereferencing "str" (line #620) before a null check.

Version-Release number of selected component (if applicable):
1.7-4

Additional info:
These defects were found by analysis of coverity scan report.

Comment 3 David Teigland 2011-08-23 16:36:20 UTC
Thanks, I'm looking at the full list and making fixes.

Comment 4 David Teigland 2011-08-23 17:05:37 UTC
made the following changes
1. handle error from direct_align
2. free mem in leader_read_multiple
3. handle null str arg in str_to_lockspace

none are a problem in practice,
1 won't happen
2 code is unused
3 invalid use

If I do another 6.2 build for other reasons, these changes will be included, otherwise not.  Don't know what state to put this bz in.

Comment 7 David Teigland 2011-09-19 15:29:01 UTC

*** This bug has been marked as a duplicate of bug 658971 ***


Note You need to log in before you can comment on or make changes to this bug.