Bug 732747 - no error message to indicate that the repo is no longer available if you delete a repo after scheduling an errata install
Summary: no error message to indicate that the repo is no longer available if you dele...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: z_other
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Sayli Karmarkar
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 13:27 UTC by Preethi Thomas
Modified: 2015-03-23 01:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-24 20:15:05 UTC


Attachments (Terms of Use)

Description Preethi Thomas 2011-08-23 13:27:40 UTC
Description of problem:

If a schedule multiple errata install and then go on to delete the repo, the first errata finish the install but the the remaining ones does not, but there is no message that indicates that. It just displays the one that is installed.

[root@preethi ~]# pulp-admin -u admin -p admin errata install --consumerid=pulp-client -e FEDORA-2010-17189 -e FEDORA-2010-17189 -e FEDORA-2011-8647 -e FEDORA-2011-8640
Created task id: fb5d8935-cd87-11e0-ba94-002564a85a58
Waiting: [\] 
Errata applied to [pulp-client]; packages installed: ['libcurl-7.21.0-5.fc14.x86_64', 'coreutils-libs-8.5-6.fc14.x86_64', 'firefox-3.6.20-1.fc14.x86_64', 'firefox-3.6.17-1.fc14.x86_64', 'xulrunner-1.9.2.20-1.fc14.x86_64', 'xulrunner-1.9.2.17-2.fc14.x86_64', 'libcurl-7.21.0-8.fc14.x86_64', 'coreutils-8.5-7.fc14.x86_64', 'coreutils-libs-8.5-7.fc14.x86_64', 'coreutils-8.5-6.fc14.x86_64', 'curl-7.21.0-5.fc14.x86_64', 'curl-7.21.0-8.fc14.x86_64']


Version-Release number of selected component (if applicable):
[root@preethi ~]# rpm -q pulp
pulp-0.0.226-1.fc14.noarch

Comment 1 Preethi Thomas 2011-08-24 15:59:34 UTC
pulp.log
2011-08-23 09:01:06,850 7642:140305894463232: pulp.server.webservices.controllers.services:INFO: services:337 agent status:   GET received
2011-08-23 09:01:14,260 7642:140305835714304: pulp.server.api.consumer:ERROR: consumer:528 Packages to install [[u'coreutils-libs', u'coreutils', u'coreutils-libs', u'coreutils', u'coreutils-libs', u'coreutils', u'coreutils-libs', u'coreutils', u'xulrunner', u'xulrunner', u'firefox', u'firefox', u'libcurl', u'curl', u'libcurl', u'curl']]
2011-08-23 09:01:14,386 7642:140305433093888: gofer.rmi.policy:INFO: policy:139 sent (pulp-client):
{
  "classname": "Packages",
  "kws": {},
  "args": [
    [
      "coreutils-libs",
      "coreutils",
      "coreutils-libs",
      "coreutils",
      "coreutils-libs",
      "coreutils",
      "coreutils-libs",
      "coreutils",
      "xulrunner",
      "xulrunner",
      "firefox",
      "firefox",
      "libcurl",
      "curl",
      "libcurl",
      "curl"
    ],
    false,
    false
  ],
  "method": "install"
}
2011-08-23 09:01:23,812 7642:140305835714304: pulp.server.api.repo:INFO: repo:471 Delete API call invoked f14-updates
2011-08-23 09:01:23,824 7642:140305835714304: pulp.server.api.keystore:INFO: keystore:185 unlinking: /var/lib/pulp/published/gpg/pub/fedora/linux/updates/14/x86_64
2011-08-23 09:01:44,222 7642:140305433093888: pulp.server.tasking.task:INFO: task:367 Task succeeded: Task fb5d8935-cd87-11e0-ba94-002564a85a58: ConsumerApi.__installpackages(pulp-client, [u'coreutils-libs', u'coreutils', u'coreutils-libs', u'coreutils', u'coreutils-libs', u'coreutils', u'coreutils-libs', u'coreutils', u'xulrunner', u'xulrunner', u'firefox', u'firefox', u'libcurl', u'curl', u'libcurl', u'curl'], reboot=False, assumeyes=False)
2011-08-23 09:06:04,381 7642:140305835714304: pulp.server.api.repo:ERROR: repo:533 'NoneType' object is not subscriptable
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/api/repo.py", line 527, in delete
    self.errataapi.delete(eid)
  File "/usr/lib/python2.7/site-packages/pulp/server/api/errata.py", line 82, in delete
    if self.referenced(id):
  File "/usr/lib/python2.7/site-packages/pulp/server/api/errata.py", line 94, in referenced
    type = self.erratum(id)["type"]
TypeError: 'NoneType' object is not subscriptable
2011-08-23 09:06:04,382 7642:140305835714304: pulp.server.api.repo:ERROR: repo:533 'NoneType' object is not subscriptable
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/api/repo.py", line 527, in delete
    self.errataapi.delete(eid)
  File "/usr/lib/python2.7/site-packages/pulp/server/api/errata.py", line 82, in delete
    if self.referenced(id):
  File "/usr/lib/python2.7/site-packages/pulp/server/api/errata.py", line 94, in referenced
type = self.erratum(id)["type"]
TypeError: 'NoneType' object is not subscriptable
2011-08-23 09:06:04,384 7642:140305835714304: pulp.server.api.repo:ERROR: repo:533 'NoneType' object is not subscriptable
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/api/repo.py", line 527, in delete
    self.errataapi.delete(eid)
  File "/usr/lib/python2.7/site-packages/pulp/server/api/errata.py", line 82, in delete
    if self.referenced(id):
  File "/usr/lib/python2.7/site-packages/pulp/server/api/errata.py", line 94, in referenced
    type = self.erratum(id)["type"]
TypeError: 'NoneType' object is not subscriptable
2011-08-23 09:06:04,385 7642:140305835714304: pulp.server.api.repo:ERROR: repo:533 'NoneType' object is not subscriptable
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/api/repo.py", line 527, in delete
    self.errataapi.delete(eid)
  File "/usr/lib/python2.7/site-packages/pulp/server/api/errata.py", line 82, in delete
    if self.referenced(id):
  File "/usr/lib/python2.7/site-packages/pulp/server/api/errata.py", line 94, in referenced
    type = self.erratum(id)["type"]
TypeError: 'NoneType' object is not subscriptable
2011-08-23 09:06:04,564 7642:140305835714304: pulp.server.api.repo:INFO: repo:553 Unsubscribe repoid f14-updates from consumer pulp-client
2011-08-23 09:06:04,746 7642:140305835714304: gofer.rmi.policy:INFO: policy:236 sent (pulp-client):
{
  "classname": "Consumer",
  "kws": {},
  "args": [
    "f14-updates"
  ],
  "method": "unbind"
}
2011-08-23 09:06:04,749 7642:140305835714304: pulp.server.api.repo:INFO: repo:553 Unsubscribe repoid f14-updates from consumer peethi
2011-08-23 09:06:05,189 7642:140305835714304: gofer.rmi.policy:INFO: policy:236 sent (peethi):
{
  "classname": "Consumer",
  "kws": {},
  "args": [
    "f14-updates"
  ],
  "method": "unbind"
}
2011-08-23 09:06:06,899 7642:140305835714304: pulp.server.api.repo:INFO: repo:574 removing repo files .... /var/lib/pulp//repos/pub/fedora/linux/updates/14/x86_64
2011-08-23 09:06:06,931 7642:140305835714304: pulp.repo_auth.repo_cert_utils:INFO: repo_cert_utils:87 Deleting certificate bundles at [/etc/pki/content/f14-updates]

Comment 2 Sayli Karmarkar 2012-01-09 06:15:03 UTC
Unable to reproduce. Preethi, can you try and see if this is still happening? In my case, errata install always succeeds. I am guessing because of asynchronous repo delete, we might be checking whether there are any pending package/errata installs on a given repo before deleting it.

Comment 3 Preethi Thomas 2012-01-09 14:57:54 UTC
[root@preethi ~]# rpm -q pulp
pulp-0.0.256-1.fc15.noarch
[root@preethi ~]# 

I get this now if the repo is deleted after scheduling errata instaal

[root@preethi ~]# pulp-admin errata install  --consumerid=el6-client -e RHBA-2011:1779 RHBA-2011:1395 -e RHBA-2011:0801 -e RHBA-2011:1836 -e RHEA-2011:1810
Created task id: a5175d4a-3ad3-11e1-bf8a-002564a85a58
Waiting: [\] 
Errata install failed: ['Errors were encountered while downloading packages.', 'libipa_hbac-python-1.5.1-66.el6_2.1.x86_64: failure: Packages/libipa_hbac-python-1.5.1-66.el6_2.1.x86_64.rpm from rhel6_x86_64_preserve: [Errno 256] No more mirrors to try.', 'libipa_hbac-1.5.1-66.el6_2.1.x86_64: failure: Packages/libipa_hbac-1.5.1-66.el6_2.1.x86_64.rpm from rhel6_x86_64_preserve: [Errno 256] No more mirrors to try.', 'python-qpid-0.12-1.el6.noarch: failure: Packages/python-qpid-0.12-1.el6.noarch.rpm from rhel6_x86_64_preserve: [Errno 256] No more mirrors to try.', 'sssd-client-1.5.1-66.el6_2.1.x86_64: failure: Packages/sssd-client-1.5.1-66.el6_2.1.x86_64.rpm from rhel6_x86_64_preserve: [Errno 256] No more mirrors to try.', 'sssd-1.5.1-66.el6_2.1.x86_64: failure: Packages/sssd-1.5.1-66.el6_2.1.x86_64.rpm from rhel6_x86_64_preserve: [Errno 256] No more mirrors to try.']

Comment 4 Preethi Thomas 2012-02-24 20:15:05 UTC
Pulp v1.0 is released
Closed Current Release.

Comment 5 Preethi Thomas 2012-02-24 20:16:47 UTC
Pulp v1.0 is released.


Note You need to log in before you can comment on or make changes to this bug.