Bug 732962 - long pause after installing last package, grubby fatal error
long pause after installing last package, grubby fatal error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-24 06:24 EDT by Jurgen Kramer
Modified: 2011-11-25 10:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-25 10:14:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2011-08-24 06:24:26 EDT
Description of problem:
After anaconda installs the last package there is a long pause before installing the bootloader. Install.log reveals grubby fatal error

Version-Release number of selected component (if applicable):
anaconda-16.14.6-1

How reproducible:
always

Steps to Reproduce:
1. Run installer
2.
3.
  
Actual results:
long pause after installing last package, install log shows grubby fatal error

Expected results:
no long pause

Additional info:
Last lines of install.log:

09:30:53 Installing iwl4965-firmware-228.61.2.24-3.fc15.noarch
09:30:53 Installing ipw2100-firmware-1.3-12.fc15.noarch
grubby fatal error: unable to find a suitable template
grubby: doing this would leave no kernel entries. Not writing out new config.
*** FINISHED INSTALLING PACKAGES ***

The logs do not reveal with what parameters grubby is called. How can I debug this further?

This is probably related to my bug BZ#730124
Comment 1 Mads Kiilerich 2011-11-25 10:14:01 EST
The pause is caused by rpm running a number of package post scripts and for example building kernel initrd.

The "suitable template" message is not important and well known and there is no need for debugging. The boot loader configuration will be created later.

Note You need to log in before you can comment on or make changes to this bug.