Bug 733001 - Build Error in conductor while building the rpms from src
Summary: Build Error in conductor while building the rpms from src
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
Assignee: Angus Thomas
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 12:37 UTC by Aziza Karol
Modified: 2012-05-15 21:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 21:52:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0583 normal SHIPPED_LIVE new packages: aeolus-conductor 2012-05-15 22:31:59 UTC

Description Aziza Karol 2011-08-24 12:37:19 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.$ sudo wget -O /etc/yum.repos.d/fedora-aeolus-testing.repo \
  http://repos.fedorapeople.org/repos/aeolus/conductor/testing/fedora-aeolus-testing.repo

2.sudo yum install aeolus-all

3.Follow the steps mention in http://www.aeolusproject.org/compiling.html#conduct
  
Error observed in make rpms: 
Actual results:
+ compass compile --output-style compact
directory public/stylesheets/compiled/
  compile app/stylesheets/custom.scss
   create public/stylesheets/compiled/custom.css
  compile app/stylesheets/login.scss
   create public/stylesheets/compiled/login.css
  compile app/stylesheets/layout.scss
   create public/stylesheets/compiled/layout.css
  compile app/stylesheets/grid.scss
   create public/stylesheets/compiled/grid.css
  compile app/stylesheets/application.scss
   create public/stylesheets/compiled/application.css
  compile app/stylesheets/text.scss
    error app/stylesheets/text.scss (Line 25: Undefined variable: "$screenfont".)
   create public/stylesheets/compiled/text.css


Expected results:


Additional info:
[root@kvm-guest-06 aeolus-script]# ls -la ~/rpmbuild/RPMS/noarch/
total 1408
drwxr-xr-x. 2 root root    4096 Aug 24 12:34 .
drwxr-xr-x. 3 root root    4096 Aug 24 12:34 ..
-rw-r--r--. 1 root root    2429 Aug 24 12:34 aeolus-all-0.4.0-0.20110824163434gitcf40883.fc15.noarch.rpm
-rw-r--r--. 1 root root 1334761 Aug 24 12:34 aeolus-conductor-0.4.0-0.20110824163434gitcf40883.fc15.noarch.rpm
-rw-r--r--. 1 root root   15125 Aug 24 12:34 aeolus-conductor-daemons-0.4.0-0.20110824163434gitcf40883.fc15.noarch.rpm
-rw-r--r--. 1 root root   63181 Aug 24 12:34 aeolus-conductor-devel-0.4.0-0.20110824163434gitcf40883.fc15.noarch.rpm
-rw-r--r--. 1 root root   10933 Aug 24 12:34 aeolus-conductor-doc-0.4.0-0.20110824163434gitcf40883.fc15.noarch.rpm

Comment 1 Jozef Zigmund 2011-09-26 15:10:37 UTC
Tested in recent master branch, last commit 898bba3ba74d08d082c751537b06ed53d6d314b8. Building via 'make rpms' works right.

Comment 2 wes hayutin 2011-09-28 16:38:17 UTC
making sure all the bugs are at the right version for future queries

Comment 4 Aziza Karol 2011-10-10 07:04:05 UTC
Building rpms works.

[root@dell-pesc430-03 conductor]# ls -la ~/rpmbuild/RPMS/noarch/
total 1436
drwxr-xr-x. 2 root root    4096 Oct 10 03:00 .
drwxr-xr-x. 3 root root    4096 Oct 10 03:00 ..
-rw-r--r--. 1 root root    2545 Oct 10 03:00 aeolus-all-0.5.0-0.20111010070038gitc889c85.fc15.noarch.rpm
-rw-r--r--. 1 root root 1357797 Oct 10 03:00 aeolus-conductor-0.5.0-0.20111010070038gitc889c85.fc15.noarch.rpm
-rw-r--r--. 1 root root   15509 Oct 10 03:00 aeolus-conductor-daemons-0.5.0-0.20111010070038gitc889c85.fc15.noarch.rpm
-rw-r--r--. 1 root root   66529 Oct 10 03:00 aeolus-conductor-devel-0.5.0-0.20111010070038gitc889c85.fc15.noarch.rpm
-rw-r--r--. 1 root root   11221 Oct 10 03:00 aeolus-conductor-doc-0.5.0-0.20111010070038gitc889c85.fc15.noarch.rpm

Comment 6 errata-xmlrpc 2012-05-15 21:52:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html


Note You need to log in before you can comment on or make changes to this bug.