Bug 733013 - package matahari-selinux should not exists
Summary: package matahari-selinux should not exists
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: alpha
: ---
Assignee: Andrew Beekhof
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 13:10 UTC by Branislav Náter
Modified: 2016-04-26 14:15 UTC (History)
6 users (show)

Fixed In Version: matahari-0.4.2-9.el6
Doc Type: Bug Fix
Doc Text:
No description required
Clone Of:
Environment:
Last Closed: 2011-12-06 11:40:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Branislav Náter 2011-08-24 13:10:52 UTC
Description of problem:
matahari-selinux rules are now included in selinux-policy package. matahari-selinux package should be removed (obsoleted). When we try to do "yum update" on current tree, we get following error:

# yum update
<snip>
--> Finished Dependency Resolution
Error: Package: matahari-selinux-0.4.2-7.el6.i686 (@rhel6)
           Requires: matahari = 0.4.2-7.el6
           Removing: matahari-0.4.2-7.el6.i686 (@rhel6)
               matahari = 0.4.2-7.el6
           Updated By: matahari-0.4.2-8.el6.i686 (rhel6)
               matahari = 0.4.2-8.el6
           Available: matahari-0.4.0-5.el6.i686 (rhel-i386-server-6)
               matahari = 0.4.0-5.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. yum update

Actual results:
see description of problem

Expected results:
smooth update

Comment 1 Miroslav Grepl 2011-08-24 13:17:47 UTC
Looks like we will need to obsolete matahari-selinux package.

Comment 2 Daniel Walsh 2011-08-24 16:02:16 UTC
Why is this our bug?

Comment 3 Perry Myers 2011-08-24 16:48:58 UTC
(In reply to comment #2)
> Why is this our bug?

@dwalsh: Don't know.  mgrepl was the one who moved this from matahari to selinux-policy, so probably check with him

Comment 6 Dave Johnson 2011-08-24 19:42:05 UTC
good 2 go in v0.4.2-9

Comment 7 Dave Johnson 2011-08-24 19:42:28 UTC
good 2 go in v0.4.2-9, moving to verified

Comment 8 Miroslav Grepl 2011-08-24 20:51:15 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Why is this our bug?
> 
> @dwalsh: Don't know.  mgrepl was the one who moved this from matahari to
> selinux-policy, so probably check with him

Yeap, by accident.

Comment 9 Russell Bryant 2011-11-16 21:51:31 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required

Comment 10 errata-xmlrpc 2011-12-06 11:40:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.