Bug 733015 - rake aborted! error while building rpms from src in audrey
Summary: rake aborted! error while building rpms from src in audrey
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configserver
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Greg Blomquist
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 13:12 UTC by Aziza Karol
Modified: 2012-01-26 12:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-09 14:54:19 UTC


Attachments (Terms of Use)

Description Aziza Karol 2011-08-24 13:12:55 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
Steps to Reproduce:
1.$ sudo wget -O /etc/yum.repos.d/fedora-aeolus-testing.repo \
 
http://repos.fedorapeople.org/repos/aeolus/conductor/testing/fedora-aeolus-testing.repo

2.sudo yum install aeolus-all

3.Follow the steps mention in
http://www.aeolusproject.org/compiling.html#audrey

[root@kvm-guest-06 audrey]# rake rpm --trace
rake aborted!
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb, Rakefile.rb)
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:489:in `raw_load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:78:in `load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:129:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:77:in `load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:61:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:129:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:59:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/bin/rake:32
/usr/bin/rake:19:in `load'
/usr/bin/rake:19


Actual results:


Expected results:


Additional info:

Comment 1 Greg Blomquist 2011-08-31 15:00:10 UTC
Hi Aziza

It looks like you're not in the right directory.  You're trying to build from the root repository directory.  But, you should be in the "configserver" directory.

The docs show:

3. Build the RPMs

$ cd audrey/configserver
$ rake rpm

That "configserver" part of the first command is key.

Comment 2 Aziza Karol 2011-09-23 08:38:22 UTC
Hi Greg,

I tried building from configserver directory and still i get rake aborted and rpmbuild failed at the end.

[root@nec-em15 configserver]# rake rpm
rake/gempackagetask is deprecated.  Use rubygems/package_task instead
tar zcvf aeolus-configserver-0.2.3.tgz aeolus-configserver-0.2.3
aeolus-configserver-0.2.3/
aeolus-configserver-0.2.3/conf/
aeolus-configserver-0.2.3/conf/aeolus-configserver.sysconf
aeolus-configserver-0.2.3/conf/aeolus-configserver
aeolus-configserver-0.2.3/conf/aeolus-configserver-proxy.sysconf
aeolus-configserver-0.2.3/configure/
aeolus-configserver-0.2.3/configure/bin/
aeolus-configserver-0.2.3/configure/bin/config_httpd.sh
aeolus-configserver-0.2.3/configure/puppet/
aeolus-configserver-0.2.3/configure/puppet/modules/
aeolus-configserver-0.2.3/configure/puppet/modules/apache/
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/vhost.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/vhost80.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/auth_config.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/aeolus-configserver-proxy.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/vhost443.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/manifests/
aeolus-configserver-0.2.3/configure/puppet/modules/apache/manifests/init.pp
aeolus-configserver-0.2.3/configure/puppet/modules/configserver/
aeolus-configserver-0.2.3/configure/puppet/modules/configserver/manifests/
aeolus-configserver-0.2.3/configure/puppet/modules/configserver/manifests/init.pp
aeolus-configserver-0.2.3/schema/
aeolus-configserver-0.2.3/schema/instance-config.rng
aeolus-configserver-0.2.3/schema/assembly.rng
aeolus-configserver-0.2.3/schema/deployable.rng
aeolus-configserver-0.2.3/schema/template.rng
aeolus-configserver-0.2.3/src/
aeolus-configserver-0.2.3/src/configserver.rb
aeolus-configserver-0.2.3/src/config.ru
aeolus-configserver-0.2.3/src/lib/
aeolus-configserver-0.2.3/src/lib/config_handler.rb
aeolus-configserver-0.2.3/src/lib/model.rb
aeolus-configserver-0.2.3/src/lib/model/
aeolus-configserver-0.2.3/src/lib/model/base.rb
aeolus-configserver-0.2.3/src/lib/model/instance.rb
aeolus-configserver-0.2.3/src/lib/model/deployable.rb
aeolus-configserver-0.2.3/src/lib/application_helper.rb
aeolus-configserver-0.2.3/client/
aeolus-configserver-0.2.3/client/cs-input
aeolus-configserver-0.2.3/client/cs-client
aeolus-configserver-0.2.3/COPYING
aeolus-configserver-0.2.3/Rakefile
rake aborted!
rpmbuild failed


Thanks,
Aziza

Comment 3 wes hayutin 2011-09-28 16:37:05 UTC
making sure all the bugs are at the right version for future queries

Comment 5 Greg Blomquist 2011-10-25 17:45:48 UTC
Aziza, can I get a copy of the rpmbuild.log file that's produced by the build?  I can't reproduce this problem when building locally.

Comment 6 Aziza Karol 2011-10-26 04:11:55 UTC
This issue is not reproducible now.
Building rpms from src is successful.

[root@dell-pesc430-03 configserver]# rake rpm
rake/gempackagetask is deprecated.  Use rubygems/package_task instead
tar zcvf aeolus-configserver-0.2.3.tgz aeolus-configserver-0.2.3
aeolus-configserver-0.2.3/
aeolus-configserver-0.2.3/client/
aeolus-configserver-0.2.3/client/cs-client
aeolus-configserver-0.2.3/client/cs-input
aeolus-configserver-0.2.3/COPYING
aeolus-configserver-0.2.3/Rakefile
aeolus-configserver-0.2.3/schema/
aeolus-configserver-0.2.3/schema/deployable.rng
aeolus-configserver-0.2.3/schema/template.rng
aeolus-configserver-0.2.3/schema/instance-config.rng
aeolus-configserver-0.2.3/schema/assembly.rng
aeolus-configserver-0.2.3/configure/
aeolus-configserver-0.2.3/configure/puppet/
aeolus-configserver-0.2.3/configure/puppet/modules/
aeolus-configserver-0.2.3/configure/puppet/modules/apache/
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/auth_config.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/vhost80.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/vhost.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/aeolus-configserver-proxy.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/templates/vhost443.erb
aeolus-configserver-0.2.3/configure/puppet/modules/apache/manifests/
aeolus-configserver-0.2.3/configure/puppet/modules/apache/manifests/init.pp
aeolus-configserver-0.2.3/configure/puppet/modules/configserver/
aeolus-configserver-0.2.3/configure/puppet/modules/configserver/manifests/
aeolus-configserver-0.2.3/configure/puppet/modules/configserver/manifests/init.pp
aeolus-configserver-0.2.3/configure/bin/
aeolus-configserver-0.2.3/configure/bin/config_httpd.sh
aeolus-configserver-0.2.3/src/
aeolus-configserver-0.2.3/src/config.ru
aeolus-configserver-0.2.3/src/lib/
aeolus-configserver-0.2.3/src/lib/config_handler.rb
aeolus-configserver-0.2.3/src/lib/model/
aeolus-configserver-0.2.3/src/lib/model/base.rb
aeolus-configserver-0.2.3/src/lib/model/instance.rb
aeolus-configserver-0.2.3/src/lib/model/deployable.rb
aeolus-configserver-0.2.3/src/lib/application_helper.rb
aeolus-configserver-0.2.3/src/lib/model.rb
aeolus-configserver-0.2.3/src/configserver.rb
aeolus-configserver-0.2.3/conf/
aeolus-configserver-0.2.3/conf/aeolus-configserver.sysconf
aeolus-configserver-0.2.3/conf/aeolus-configserver-proxy.sysconf
aeolus-configserver-0.2.3/conf/aeolus-configserver
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.vfz0uK
+ umask 022
+ cd /root/rpmbuild/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /root/rpmbuild/BUILD
+ rm -rf aeolus-configserver-0.2.3
+ /usr/bin/gzip -dc /root/audrey/configserver/pkg/aeolus-configserver-0.2.3.tgz
+ /bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd aeolus-configserver-0.2.3
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ LANG=C
+ export LANG
+ unset DISPLAY
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.llmQ3n
+ umask 022
+ cd /root/rpmbuild/BUILD
+ '[' /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64 '!=' / ']'
+ rm -rf /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64
++ dirname /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64
+ mkdir -p /root/rpmbuild/BUILDROOT
+ mkdir /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64
+ cd aeolus-configserver-0.2.3
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/usr/share/aeolus-configserver
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/etc/rc.d/init.d
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/etc/sysconfig
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/etc/aeolus-configserver
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/var/lib/aeolus-configserver/schema
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/var/log/aeolus-configserver
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/var/run/aeolus-configserver
+ /bin/cp -R src/config.ru src/configserver.rb src/lib /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64//usr/share/aeolus-configserver
+ /bin/cp conf/aeolus-configserver /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64//etc/rc.d/init.d
+ /bin/cp conf/aeolus-configserver.sysconf /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/etc/sysconfig/aeolus-configserver
+ /bin/cp schema/assembly.rng schema/deployable.rng schema/instance-config.rng schema/template.rng /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/var/lib/aeolus-configserver/schema/
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/usr/share/aeolus-configserver/configure
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/usr/bin
+ /bin/cp -R configure/puppet /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/usr/share/aeolus-configserver/configure/
+ /bin/cp configure/bin/config_httpd.sh /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/usr/bin/aeolus-configserver-setup-httpd
+ /bin/cp conf/aeolus-configserver-proxy.sysconf /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/etc/sysconfig/aeolus-configserver-proxy
+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+ /usr/lib/rpm/redhat/brp-python-hardlink
+ /usr/lib/rpm/redhat/brp-java-repack-jars
Processing files: aeolus-configserver-0.2.3-4.fc15.noarch
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.x7uLu3
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd aeolus-configserver-0.2.3
+ DOCDIR=/root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/usr/share/doc/aeolus-configserver-0.2.3
+ export DOCDIR
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/usr/share/doc/aeolus-configserver-0.2.3
+ cp -pr COPYING /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64/usr/share/doc/aeolus-configserver-0.2.3
+ exit 0
Provides: config(aeolus-configserver) = 0.2.3-4.fc15
Requires(interp): /bin/sh /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(pre): /bin/sh
Requires(post): /bin/sh chkconfig
Requires(preun): /bin/sh chkconfig initscripts
Requires: /bin/bash
Processing files: aeolus-configserver-proxy-0.2.3-4.fc15.noarch
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: /bin/bash
Checking for unpackaged file(s): /usr/lib/rpm/check-files /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64
Wrote: /root/rpmbuild/SRPMS/aeolus-configserver-0.2.3-4.fc15.src.rpm
Wrote: /root/rpmbuild/RPMS/noarch/aeolus-configserver-0.2.3-4.fc15.noarch.rpm
Wrote: /root/rpmbuild/RPMS/noarch/aeolus-configserver-proxy-0.2.3-4.fc15.noarch.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.xVl2HL
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd aeolus-configserver-0.2.3
+ rm -rf /root/rpmbuild/BUILDROOT/aeolus-configserver-0.2.3-4.fc15.x86_64
+ exit 0


[root@dell-pesc430-03 noarch]# ll /root/rpmbuild/RPMS/noarch
total 40
-rw-r--r--. 1 root root 27721 Oct 25 23:29 aeolus-configserver-0.2.3-4.fc15.noarch.rpm
-rw-r--r--. 1 root root  9681 Oct 25 23:29 aeolus-configserver-proxy-0.2.3-4.fc15.noarch.rpm

Comment 7 Greg Blomquist 2011-11-14 18:12:13 UTC
So, notabug?  What should the appropriate status on this bug be?

Comment 8 Greg Blomquist 2011-12-09 14:54:19 UTC
I'm closing this as notabug.


Note You need to log in before you can comment on or make changes to this bug.