Bug 733020 - "fatal: Not a git repository (or any of the parent directories): .git" error observed while building rpms in image factory
Summary: "fatal: Not a git repository (or any of the parent directories): .git" error...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Ian McLeod
QA Contact: Brad P. Crochet
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 13:23 UTC by Aziza Karol
Modified: 2012-05-15 20:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:10:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0588 normal SHIPPED_LIVE new packages: imagefactory 2012-05-15 22:31:27 UTC

Description Aziza Karol 2011-08-24 13:23:54 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.$ sudo wget -O /etc/yum.repos.d/fedora-aeolus-testing.repo \

http://repos.fedorapeople.org/repos/aeolus/conductor/testing/fedora-aeolus-testing.repo

2.sudo yum install aeolus-all

3.Follow the steps mention in
http://www.aeolusproject.org/compiling.html#factory


[root@kvm-guest-06 imagefactory]# make rpm
python setup.py sdist
running sdist
running check
warning: sdist: standard file not found: should have one of README, README.txt
.......
......
+ unset DISPLAY
+ python setup.py build
fatal: Not a git repository (or any of the parent directories): .git
running build
running build_py

  
Actual results:


Expected results:


Additional info:

Comment 1 wes hayutin 2011-09-28 16:40:53 UTC
making sure all the bugs are at the right version for future queries

Comment 3 wes hayutin 2012-01-12 16:52:51 UTC
adding to sprint tracker

Comment 4 Brad P. Crochet 2012-01-16 22:54:18 UTC
No longer seems to be an issue. 
b08eb85b41240613e46ebdef5af5cbdc396970a9

Comment 6 errata-xmlrpc 2012-05-15 20:10:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0588.html


Note You need to log in before you can comment on or make changes to this bug.