Bug 733150 - matahari sysconfig crash on is_configured()
Summary: matahari sysconfig crash on is_configured()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Russell Bryant
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-24 21:59 UTC by Dave Johnson
Modified: 2011-12-06 11:40 UTC (History)
2 users (show)

Fixed In Version: matahari-0.4.3-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
No description required
Clone Of:
Environment:
Last Closed: 2011-12-06 11:40:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
core dump (5.80 MB, application/octet-stream)
2011-08-24 21:59 UTC, Dave Johnson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-24 21:59:08 UTC
Created attachment 519730 [details]
core dump

Description of problem:
=======================================
execute is_configured() and the matahari sysconfig agent crashes

Version-Release number of selected component (if applicable):
===============================================================
v0.4.2-9

How reproducible:
=======================================
100%

Steps to Reproduce:
=======================================
1.  install/start matahari broker
2.  install/start matahari sysconfig agent
3.  (optional) with qmf-tool, call 2 run_string 'file { "/etc/sudoers":\n     owner => root, group => root, mode => 440\n}\n' 0 puppet dave
4.  use qmf-tool to 'call n is_configured dave',  segfaults even when step 3 is skipped


Additional info:
======================
process spit out:
    terminate called after throwing an instance of 'qmf::QmfException'
      what():  Property 'is_postboot_configured' either not in the schema or    
      value is of incompatible type
    Aborted (core dumped)


(gdb) bt full
#0  0x40000416 in __kernel_vsyscall ()
No symbol table info available.
#1  0x002cfbb1 in raise () from /lib/libc.so.6
No symbol table info available.
#2  0x002d148a in abort () from /lib/libc.so.6
No symbol table info available.
#3  0x00687327 in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
No symbol table info available.
#4  0x00685186 in ?? () from /usr/lib/libstdc++.so.6
No symbol table info available.
#5  0x006851c3 in std::terminate() () from /usr/lib/libstdc++.so.6
No symbol table info available.
#6  0x00685302 in __cxa_throw () from /usr/lib/libstdc++.so.6
No symbol table info available.
#7  0x404240c2 in qmf::DataImpl::setProperty(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, qpid::types::Variant const&) () from /usr/lib/libqmf2.so.1
No symbol table info available.
#8  0x404243ae in qmf::Data::setProperty(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, qpid::types::Variant const&) () from /usr/lib/libqmf2.so.1
No symbol table info available.
#9  0x0804abe7 in ConfigAgent::invoke (this=0xbfce8af0, session=..., event=..., user_data=0xbfce8af0) at /usr/src/debug/matahari-matahari-325f740/src/sysconfig/sysconfig-qmf.cpp:112
        status = 0x96a5500 "OK"
        methodName = <value optimized out>
        args = <value optimized out>
#10 0x4001695e in mh_qpid_callback (session=..., event=..., user_data=0xbfce8af0) at /usr/src/debug/matahari-matahari-325f740/src/lib/mh_agent.cpp:128
        agent = 0xbfce8af0
        __FUNCTION__ = "mh_qpid_callback"
#11 0x4001669f in mainloop_qmf_dispatch (source=0x96a6580, callback=0, userdata=0x0) at /usr/src/debug/matahari-matahari-325f740/src/lib/mh_agent.cpp:581
        event = {<qmf::Handle<qmf::AgentEventImpl>> = {impl = 0x40e01a50}, <No data fields>}
        qmf = 0x96a6580
        __FUNCTION__ = "mainloop_qmf_dispatch"
#12 0x004dec78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#13 0x004e25e0 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#14 0x004e29ff in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#15 0x400167fd in MatahariAgent::run (this=0xbfce8af0) at /usr/src/debug/matahari-matahari-325f740/src/lib/mh_agent.cpp:543
        __FUNCTION__ = "run"
#16 0x0804a0af in main (argc=2, argv=0xbfce8bc4) at /usr/src/debug/matahari-matahari-325f740/src/sysconfig/sysconfig-qmf.cpp:59
        agent = {<MatahariAgent> = {_vptr.MatahariAgent = 0x804e290, _impl = 0x969f530}, _package = {data_Sysconfig = {<qmf::Handle<qmf::SchemaImpl>> = {impl = 0x96a5910}, <No data fields>}}, _instance = 
    {<qmf::Handle<qmf::DataImpl>> = {impl = 0x96a6208}, <No data fields>}, static SYSCONFIG_NAME = "Sysconfig"}
        rc = 0
(gdb)

Comment 2 Russell Bryant 2011-08-25 12:10:06 UTC
I have proposed a patch for this but it hasn't been merged upstream yet.

https://github.com/russellb/matahari/commit/11aa560050f799ffa0be68c20b372391d2cda713

Comment 4 Russell Bryant 2011-08-31 19:31:45 UTC
I have added the Rebase keyword to this bug.

We really need to do one more rebase on the matahari package.  Right now we do not have a proper 1 to 1 mapping between bugs and patches.  I just made an upstream release today that includes everything that we have in the patches plus some additional fixes for bugs fixed in the last week.  It's going to be best long term if we rebase to that now.

Comment 6 Dave Johnson 2011-09-09 18:27:54 UTC
good 2 go in v0.4.4-2

Comment 7 Russell Bryant 2011-11-16 21:53:48 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required

Comment 8 errata-xmlrpc 2011-12-06 11:40:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.