Bug 733180 - Usb stick passthrough failed under ehci
Summary: Usb stick passthrough failed under ehci
Keywords:
Status: CLOSED DUPLICATE of bug 733272
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 03:05 UTC by Shaolong Hu
Modified: 2011-09-12 09:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-12 09:03:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Shaolong Hu 2011-08-25 03:05:57 UTC
Description of problem:
-------------------------
Passthrough usb disk to gust, usb device can be detected in guest, but fail to be used.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
host:
qemu-kvm-0.12.1.2-2.184.el6.x86_64
2.6.32-191.el6.x86_64
guest:
2.6.32-188.el6.x86_64


How reproducible:
------------------
100%


Steps to Reproduce:
--------------------
1.boot guest:
# /usr/libexec/qemu-kvm -enable-kvm -M rhel6.2.0 -smp 4 -m 4G -name rhel6.2-64 -uuid 3f2ea5cd-3d29-48ff-aab2-23df1b6ae213 -drive file=RHEL-Server-6.2-64-virtio.qcow2,cache=none,if=none,rerror=stop,werror=stop,id=drive-virtio-disk0,format=qcow2 -device virtio-blk-pci,drive=drive-virtio-disk0,id=device-virtio-disk0,bootindex=1 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0 -boot order=cd,menu=on -monitor stdio -vnc :10 -device usb-ehci,id=ehci -device usb-host,bus=ehci.0,hostbus=1,hostaddr=2

  
Actual results:
------------------
1.in qemu monitor
*** EHCI support is under development ***
husb: open device 1.2
husb: config #1 need -1
husb: 1 interfaces claimed for configuration 1
husb: grabbed usb device 1.2
husb: config #1 need 1
husb: 1 interfaces claimed for configuration 1
husb: config #1 need 1
husb: 1 interfaces claimed for configuration 1

2.in qemu monitor
(qemu) info usbhost
husb: using sys file-system with /dev/bus/usb
  Bus 1, Addr 2, Port 1, Speed 480 Mb/s
    Class 00: USB device 0781:5567, Cruzer Blade
  Bus 7, Addr 2, Port 1, Speed 12 Mb/s
    Hub: USB device 0557:7000
  Bus 7, Addr 3, Port 1.1, Speed 1.5 Mb/s
    Class 00: USB device 0557:2213, CS-1734A V4.2.411

3.in the guest:
#dmesg
usb-storage: device scan complete
scsi 2:0:0:0: Direct-Access     SanDisk  Cruzer Blade     1.19 PQ: 0 ANSI: 5
EXT4-fs (vda1): mounted filesystem with ordered data mode. Opts:
scsi 2:0:0:0: Attached scsi generic sg1 type 0
sd 2:0:0:0: [sda] 31266816 512-byte logical blocks: (16.0 GB/14.9 GiB)
Adding 2064376k swap on /dev/mapper/vg_dhcp6673237-lv_swap.  Priority:-1 extents:1 across:2064376k
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
usb 1-1: reset high speed USB device using ehci_hcd and address 2
usb 1-1: reset high speed USB device using ehci_hcd and address 2
usb 1-1: reset high speed USB device using ehci_hcd and address 2
usb 1-1: reset high speed USB device using ehci_hcd and address 2
usb 1-1: reset high speed USB device using ehci_hcd and address 2
sd 2:0:0:0: Device offlined - not ready after error recovery
sd 2:0:0:0: [sda] Write Protect is off
sd 2:0:0:0: [sda] Mode Sense: 43 00 00 00
sd 2:0:0:0: [sda] Assuming drive cache: write through
sd 2:0:0:0: [sda] Attached SCSI removable disk

4.in the guest, there is /dev/sda, but fdisk -l don't show /dev/sda, and fdisk /dev/sda failed:“Unable to open /dev/sda”.


Expected results:
------------------
Usb device passthroughed should work correctly.

Comment 3 Gerd Hoffmann 2011-09-12 09:03:53 UTC

*** This bug has been marked as a duplicate of bug 733272 ***


Note You need to log in before you can comment on or make changes to this bug.