Bug 733210 - [virt-manager]keyboard shortcuts not take effect when focus out of guest with spice graphics
Summary: [virt-manager]keyboard shortcuts not take effect when focus out of guest with...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 06:46 UTC by zhe peng
Modified: 2012-06-20 12:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed
Clone Of:
Environment:
Last Closed: 2012-06-20 12:35:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0785 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2012-06-19 20:34:46 UTC

Description zhe peng 2011-08-25 06:46:34 UTC
Description of problem:
uncheck "Force console keyboard shortcuts",open a guest with spice graphics,make focus out of guest ,the keyboard shortcuts not take effect.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-5.el6

How reproducible:
always

Steps to Reproduce:
1.launch virt-manager,in main page,click "Edit"->"Preferences"
switch to tab "VM Details",make sure uncheck "Force console keyboard shortcuts"
2.open a guest with spice graphics,make sure can login guest.
3.make focus out of guest, e.g. switch to hardware details page
  
Actual results:
keyboard shortcuts all disabled.

Expected results:
the menu shortcuts should take effect.


Additional info:
this issue only occur when open guest with spice graphics, with vnc all worked well.
if open a spice guest first ,then open a vnc guest,the shortcuts of vnc guest all disabled,and have debug info:
2011-08-25 02:44:53,784 (console:1068): Starting connect process for proto=vnc trans=None connhost=localhost connuser=None connport=None gaddr=127.0.0.1 gport=5900 gsocket=None
2011-08-25 02:44:53,907 (console:979): Viewer connected
/usr/share/virt-manager/virtManager/console.py:694: GtkWarning: _gtk_accel_group_detach: assertion `g_slist_find (accel_group->acceleratables, object) != NULL' failed
  self.topwin.remove_accel_group(g)

Comment 2 Cole Robinson 2011-09-27 15:50:09 UTC
Not a huge priority so deferring to 6.3

Comment 4 Cole Robinson 2012-01-25 22:01:00 UTC
Moving to POST since it's upstream

Comment 5 Cole Robinson 2012-02-01 20:03:44 UTC
Fixed in virt-manager-0.9.0-8.el6

Comment 7 zhe peng 2012-02-13 03:06:20 UTC
verify with:
virt-manager-0.9.0-9.el6.x86_64
python-virtinst-0.600.0-7.el6.noarch

step:
1.launch virt-manager,in main page,click "Edit"->"Preferences"
switch to tab "VM Details",make sure uncheck "Force console keyboard shortcuts"
2.open a guest with spice graphics,make sure can login guest.
3.make focus out of guest, e.g. switch to hardware details page

now the shortcutss can worked well,no error display in debug info
verification passed. move to verified.

Comment 8 Cole Robinson 2012-06-12 15:24:44 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed

Comment 10 errata-xmlrpc 2012-06-20 12:35:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0785.html


Note You need to log in before you can comment on or make changes to this bug.