Bug 733211 - No bluetooth available in gnome with Thinkpad X300
Summary: No bluetooth available in gnome with Thinkpad X300
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 07:15 UTC by Jan Willies
Modified: 2011-08-25 08:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-25 08:39:33 UTC


Attachments (Terms of Use)

Description Jan Willies 2011-08-25 07:15:13 UTC
Description of problem: There's no bluetooth icon in gnome available with F16. It worked fine until F15. When I want to open "bluetooth" in gnome-control-center, it segfaults:

gnome-control-c[12202]: segfault at 1f0f670 ip 0000000001f0f670 sp 00007fffdcfee948 error 15

The bluetooth-led on my thinkpad is on, so I think it should be working. Here's the log messages when starting bluetooth.service:

Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: Bluetooth daemon 4.95
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: Bluetooth daemon 4.95
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: Starting SDP server
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: Starting SDP server
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: Parsing /etc/bluetooth/input.conf failed: No such file or directory
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: Parsing /etc/bluetooth/audio.conf failed: No such file or directory
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: Parsing /etc/bluetooth/input.conf failed: No such file or directory
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: Parsing /etc/bluetooth/audio.conf failed: No such file or directory
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: Listening for HCI events on hci0
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: Listening for HCI events on hci0
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: HCI dev 0 up
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: HCI dev 0 up
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <warn> bluez error getting default adapter: No such adapter
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: input-headset driver probe failed for device 00:23:B4:63:EA:66
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: input-headset driver probe failed for device 00:23:B4:63:EA:66
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: Adapter /org/bluez/12143/hci0 has been enabled
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: Adapter /org/bluez/12143/hci0 has been enabled
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <warn> (00:23:B4:63:EA:66): failed to look up interface index
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <info> BT device Harribert (00:23:B4:63:EA:66) added (DUN)
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <info> (00:23:B4:63:EA:66): new Bluetooth device (driver: 'bluez' ifindex: -1)
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <info> (00:23:B4:63:EA:66): exported as /org/freedesktop/NetworkManager/Devices/6
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <info> (00:23:B4:63:EA:66): now managed
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <info> (00:23:B4:63:EA:66): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: bluetoothd[12143]: Inquiry Cancel Failed with status 0x12
Aug 25 08:59:11 thinkpad-x300 bluetoothd[12143]: Inquiry Cancel Failed with status 0x12
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <info> (00:23:B4:63:EA:66): deactivating device (reason: 2).
Aug 25 08:59:11 thinkpad-x300 NetworkManager[758]: <info> (00:23:B4:63:EA:66): device state change: unavailable -> disconnected (reason 'none') [20 30 0]

00:23:B4:63:EA:66 appears to be my mobile phone (which is not connected atm).

[jan@jan ~]$ systemctl status bluetooth.service 
bluetooth.service - Bluetooth service
          Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
          Active: active (running) since Thu, 25 Aug 2011 08:59:11 +0200; 8min ago
        Main PID: 12143 (bluetoothd)
          CGroup: name=systemd:/system/bluetooth.service
                  └ 12143 /usr/sbin/bluetoothd -n


Version-Release number of selected component (if applicable): kernel-3.0.1-3.fc16.x86_64 and bluez-4.95-1.fc16



How reproducible: always


Steps to Reproduce:
1. boot F16
2. try to use bluetooth with gnome
3.
  
Actual results:
no dice

Expected results:
working bluetooth

Additional info:
Often "bluetoothd -n" locks up after a suspend/resume-cycle and will consume 100% of CPU. "systemctl restart bluetooth.service" helps then.

Comment 1 Bastien Nocera 2011-08-25 08:13:29 UTC
Which exact versions of gnome-bluetooth and gnome-control-center are you using?

For the 100% CPU problem, please file a separate bug.

Comment 2 Jan Willies 2011-08-25 08:20:49 UTC
will do.

gnome-bluetooth.x86_64 1:3.1.3-1.fc16
control-center.x86_64 1:3.1.4-1.fc16

Comment 3 Jan Willies 2011-08-25 08:39:33 UTC
it seems installing gnome-bluetooth.x86_64-1:3.1.4-2.fc16 from updates-testing fixed it!


Note You need to log in before you can comment on or make changes to this bug.