Bug 733296 - unbound recursion in bootloader.py
Summary: unbound recursion in bootloader.py
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 11:53 UTC by Ales Kozumplik
Modified: 2014-09-30 23:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 17:25:22 UTC


Attachments (Terms of Use)
the complete traceback (174.27 KB, text/plain)
2011-08-25 11:53 UTC, Ales Kozumplik
no flags Details

Description Ales Kozumplik 2011-08-25 11:53:13 UTC
Created attachment 519822 [details]
the complete traceback

This looks to be caused by e8ae9031f203b15ed4530e53994ae0bd94298062:

  File "/tmp/updates/pyanaconda/bootloader.py", line 1475, in _gpt_disk_has_bios_boot
    if self.stage1_device == self.stage2_device:
  File "/tmp/updates/pyanaconda/bootloader.py", line 1504, in is_valid_stage1_device
    ignored = self._gpt_disk_has_bios_boot(device)
  File "/tmp/updates/pyanaconda/bootloader.py", line 633, in stage1_devices
    if self.is_valid_stage1_device(device):
  File "/tmp/updates/pyanaconda/bootloader.py", line 228, in stage1_device
    % [d.name for d in self.stage1_devices])
  File "/tmp/updates/pyanaconda/bootloader.py", line 1475, in _gpt_disk_has_bios_boot
    if self.stage1_device == self.stage2_device:

Comment 1 Ales Kozumplik 2011-08-25 12:00:09 UTC
Dave assigning to you, I think you will know the best where to cut the loop.

I am not sure whether this happens on F16 too, I can see it on master.


Note You need to log in before you can comment on or make changes to this bug.