Bug 733299 - Rescan and show network devices after clearing blacklist in linuxrc
Summary: Rescan and show network devices after clearing blacklist in linuxrc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.1
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-25 11:58 UTC by Jan Stodola
Modified: 2011-12-06 10:41 UTC (History)
0 users

Fixed In Version: anaconda-13.21.137-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:41:19 UTC


Attachments (Terms of Use)
proposed patch (1.08 KB, text/plain)
2011-08-25 11:58 UTC, Jan Stodola
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-06 00:39:12 UTC

Description Jan Stodola 2011-08-25 11:58:23 UTC
Created attachment 519825 [details]
proposed patch

Description of problem:
When one is running installation with the "cio_ignore=all,!0.0.0009" kernel parameter and CMS config file is not used to configure devices, linuxrc offers the choice to clear blacklist. But after clearing the blacklist, user has to manually enter all values to configure the device.
It would be nice to rescan and show devices discovered after clearing the blacklist.

With anaconda-13.21.134-1.el6, user see following:
...
Scanning for available network devices... 
Autodetection found 0 devices. 
Note: There is a device blacklist active! (Clearing might take long)
c) clear blacklist, m) manual config, r) rescan, s) shell: 
c
Clearing device blacklist... 
/init: line 491: nettable: bad array subscript 
 
* NOTE: To enter default or empty values press enter twice. * 
 
Network type (qeth, lcs, ctc, ? for help). Default is qeth: 
...


With modified linuxrc script showing devices after clearing the blacklist:
...
Scanning for available network devices... 
Autodetection found 0 devices. 
Note: There is a device blacklist active! (Clearing might take long) 
c) clear blacklist, m) manual config, r) rescan, s) shell: 
c
Clearing device blacklist... 
Scanning for available network devices... 
INFO kernel:qeth: loading core functions 
INFO kernel:ctcm: CTCM driver initialized 
Autodetection found 4 devices. 
 
NUM CARD           CU      CHPID TYPE DRIVER IF      DEVICES 
  1 OSA (QDIO)     1731/01 00    OSD  qeth   eth     0.0.0a00,0.0.0a01,0.0.0a02 
  2 OSA (QDIO)     1731/01 02    OSD  qeth   eth     0.0.0c00,0.0.0c01,0.0.0c02 
  3 CTC adapter    3088/08 08    -    ctcm   ctc     0.0.0150,0.0.0151 
  4 OSA (QDIO)     1731/01 15    OSD  qeth   eth     0.0.0900,0.0.0901,0.0.0902 
 
<num>) use config, m) manual config, r) rescan, s) shell: 
INFO kernel:lcs: Loading LCS driver 
INFO kernel:vmur: z/VM virtual unit record device driver loaded. 
4
 
* NOTE: To enter default or empty values press enter twice. * 
 
Portname (1..8 characters, or ? for help). Default is no portname: 
...

Proposed patch is included in attachment.
The patch also fixes following error message:
...
/init: line 491: nettable: bad array subscript 
...

Version-Release number of selected component (if applicable):
anaconda-13.21.134-1.el6

How reproducible:
always

Steps to Reproduce:
1. do not provide any CMS config file for z/VM guest
2. start the installation with the "cio_ignore=all,!0.0.0009" kernel parameter
3. clear blacklist when asked
4. configure network device
  
Actual results:
user has to enter network type and device numbers manually

Expected results:
rescan network devices and display list of found devices

Comment 1 RHEL Product and Program Management 2011-08-25 14:50:21 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 3 Jan Stodola 2011-09-16 11:03:42 UTC
Tested with anaconda-13.21.138-1.el6:

...
Scanning for available network devices... 
Autodetection found 0 devices. 
Note: There is a device blacklist active! (Clearing might take long) 
c) clear blacklist, m) manual config, r) rescan, s) shell: 
c
Clearing device blacklist... 
Scanning for available network devices... 
INFO kernel:qeth: loading core functions 
INFO kernel:ctcm: CTCM driver initialized 
INFO kernel:lcs: Loading LCS driver 
Autodetection found 4 devices. 
 
NUM CARD           CU      CHPID TYPE DRIVER IF      DEVICES 
  1 OSA (QDIO)     1731/01 00    OSD  qeth   eth     0.0.0a00,0.0.0a01,0.0.0a02 
  2 OSA (QDIO)     1731/01 02    OSD  qeth   eth     0.0.0c00,0.0.0c01,0.0.0c02 
  3 CTC adapter    3088/08 08    -    ctcm   ctc     0.0.0150,0.0.0151 
  4 OSA (QDIO)     1731/01 15    OSD  qeth   eth     0.0.0900,0.0.0901,0.0.0902 
 
<num>) use config, m) manual config, r) rescan, s) shell: 
INFO kernel:vmur: z/VM virtual unit record device driver loaded. 
4
 
* NOTE: To enter default or empty values press enter twice. * 
 
Portname (1..8 characters, or ? for help). Default is no portname: 
...


Moving to VERIFIED

Comment 4 errata-xmlrpc 2011-12-06 10:41:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html


Note You need to log in before you can comment on or make changes to this bug.