Bug 733321 - SELinux: Could not downgrade policy file /etc/selinux/targeted/policy/policy.26, searching for an older version.
SELinux: Could not downgrade policy file /etc/selinux/targeted/policy/policy...
Status: CLOSED DUPLICATE of bug 728576
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-25 09:17 EDT by Mads Kiilerich
Modified: 2011-08-26 16:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-26 16:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2011-08-25 09:17:52 EDT
AFAICS there is no tracking of this in bugzilla:

Every time livecd-tools is run this is shown:

  Installing: selinux-policy-targeted      ##################### [725/764]
SELinux:  Could not downgrade policy file /etc/selinux/targeted/policy/policy.26, searching for an older version.
SELinux:  Could not open policy file <= /etc/selinux/targeted/policy/policy.26:  No such file or directory
load_policy:  Can't load policy:  No such file or directory

SE generally seems to work ... probably because of the precompiled policy?

I don't know if livecd-tools should do some more tricks or if SE should be changed or the warnings hould be muted ... but something should be done.

 
livecd-tools-16.3-1.fc16.x86_64
selinux-policy-targeted-3.10.0-21.fc16.noarch

Same kernel and policy version is running on the build host and in the image it is building. Enforcing is permissive.
Comment 1 Miroslav Grepl 2011-08-25 09:47:10 EDT
Have you tried Rawhide livecd-tools?
Comment 2 Mads Kiilerich 2011-08-25 10:49:49 EDT
I confirm that it works there.

So this is another bug that will be fixed by the livecd-tools update, and you recommend doing the backport ASAP?
Comment 3 Brian Lane 2011-08-26 16:18:50 EDT

*** This bug has been marked as a duplicate of bug 728576 ***

Note You need to log in before you can comment on or make changes to this bug.