Bug 73334 - (SOUND VIA82CXXX)cannot configure sound - keep hearing "Hello Hello ..."
(SOUND VIA82CXXX)cannot configure sound - keep hearing "Hello Hello ..."
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 01:12 EDT by Abhishek Thakur
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 14:04:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case (442 bytes, text/plain)
2002-12-15 10:30 EST, David Juran
no flags Details

  None (edit)
Description Abhishek Thakur 2002-09-03 01:12:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
The ouput from the pages for sndconfig(0.68) is
-------------
RH 7.3 sndconfig 0.68
A PCI sound card was found in your system. The details are:
        Model: VIA Technologies|VT82C686 AC97 Audio Controller

A sound sample ...
---------------
   audio keeps repeating "Hello    Hello"
   After few minutes I pressed ^C to kill and exit.
   The dmesg o/p includes 
-------------
Via 686a audio driver 1.9.1
ac97_codec: AC97 Audio codec, id: 0x414c:0x4710 (ALC200/200P)
via82cxxx: board #1 at 0xE000, IRQ 9
via_audio: ignoring drain playback error -512
----------
    The last line (error -512) happens when I press ^C.

Trying toopls like mpg123 crashes the system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.HW Target is HP Pavilion ZT 1135 (known to happen for ZT 1180 also)
2.Run /sbin/sndconfig
3.Follow with default responses
	

Actual Results:  I kept hearing "Hello Hello Hello ...." and nothing after that.


Expected Results:  The full audio (I am not sure what it is) should have been
played and sndconfig should have confirmed that it has initialized my sound
settings.

Additional info:
Comment 1 Abhishek Thakur 2002-09-03 01:14:40 EDT
please also see http://www.exit109.com/~jfraney/linux_on_pavilion_zt1170.html 
section "Lockup behavior: ". This seems to be related.
Comment 2 Bill Nottingham 2002-09-03 01:30:04 EDT
This sounds like a driver problem, not a sndconfig problem.
Comment 3 David Juran 2002-12-15 10:30:45 EST
Created attachment 88744 [details]
test case

Yes, it sure seems like a driver problem, and it's also present in
kernel-smp-2.4.18-18.8.0
I've created this little test prgram I'm attaching here. When I run this, it
seems to writes some 4kB. to /dev/dsp and then hangs while the first second or
so of the sound keeps looping.
It seems however that there is some timing issue involved as well. If I
decrease the buffer size, sometimes the entire files can play (though the sound
is terribly broken up)

An excerpt from lspci -vvv
00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
	Subsystem: Creative Labs SBLive! Player 5.1
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 7
	Region 0: I/O ports at b400 [size=32]
	Capabilities: [dc] Power Management version 1
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)

	Subsystem: Creative Labs Gameport Joystick
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32
	Region 0: I/O ports at b000 [size=8]
	Capabilities: [dc] Power Management version 1
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Comment 4 David Juran 2002-12-25 10:32:26 EST
This error also occurs with kernel-smp-2.4.18-19.8.0 and with
kernel-smp-2.4.20-2.2 from "Phoebe" as well.
Comment 5 David Juran 2002-12-26 10:03:58 EST
Further investigations have shown that the driver goes to sleep in
linux/drivers/sound/emu10k1/audio.c line 241 but is never awakened. 
I'm here refering to kernel-smp-2.4.18-19.8.0
Comment 6 Alan Cox 2003-06-10 14:04:58 EDT
The VIA audio should work in current errata. The comments attached about emu10k1
later are unrelated.

Note You need to log in before you can comment on or make changes to this bug.