Bug 733357 - Add boot menu option for clean install (6.2 solution)
Summary: Add boot menu option for clean install (6.2 solution)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 715597 (view as bug list)
Depends On:
Blocks: 731146
TreeView+ depends on / blocked
 
Reported: 2011-08-25 14:38 UTC by Andrew Cathrow
Modified: 2016-04-26 14:58 UTC (History)
13 users (show)

Fixed In Version: ovirt-node-2.0.2-0.3.gitcf213a7.el6
Doc Type: Bug Fix
Doc Text:
Previously, Red Hat Enterprise Virtualization did not have a boot menu option that provided a clean install. In some cases, attempting a clean install could lead to NIC devices being improperly configured. Red Hat Enterprise Virtualization now has a boot menu option which provides a clean install which properly configures NIC devices.
Clone Of:
Environment:
Last Closed: 2011-12-06 19:26:39 UTC


Attachments (Terms of Use)
Pass 1 (32.61 KB, image/png)
2011-08-25 14:48 UTC, Mike Burns
no flags Details
Version 2 (209.03 KB, image/png)
2011-08-25 15:14 UTC, Mike Burns
no flags Details
Patch (1.73 KB, patch)
2011-08-25 18:09 UTC, Mike Burns
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Andrew Cathrow 2011-08-25 14:38:28 UTC
As per IRC/rhev-devel discussion we've been seeing issues in the field with beta and need to provide a simple option for a clean installation.
Long term solution is to handle this within the installer but that's out of scope now for 6.2 so short term is to add a grub option to wipe the existing HostVG before running the installer.

Comment 1 Mike Burns 2011-08-25 14:48:47 UTC
Created attachment 519897 [details]
Pass 1

Comment 2 Mike Burns 2011-08-25 14:49:55 UTC
Attachment shows proposed changes.

Comment so far:

Update "Boot" to "Install or Upgrade"
ditto for "with serial console"

Add reinstall with serial console

Comment 3 Mike Burns 2011-08-25 15:14:15 UTC
Created attachment 519904 [details]
Version 2

Incorporate updates from previous comment

Note:  second Reinstall entry will be Reinstall with serial console

Details are shown for Reinstall with serial console

Comment 4 Mike Burns 2011-08-25 18:09:08 UTC
Created attachment 519948 [details]
Patch

Patch to add reinstall and uninstall options to the boot menu.  This provides a boot menu like the version 2 attachment with the "Reinstall with serial console" label fixed

Comment 5 Mike Burns 2011-08-26 15:26:14 UTC
Updated patch to s/vmlinux0/vmlinuz0

Comment 8 Mike Burns 2011-10-25 18:22:17 UTC
*** Bug 715597 has been marked as a duplicate of this bug. ***

Comment 9 Bryan Yount 2011-10-31 22:18:33 UTC
I like Andrew's original comment about moving the 'Uninstall' option to within the ovirt-install TUI menu. That would make it so the user doesn't have to incur an additional reboot and it would be a more obvious option. I didn't realize the Uninstall option was even on the GRUB menu until afer I'd already gone through the trouble of 'dd'ing the drive.

It seems like it would be a more obvious option for the TUI menu since you could present the use with an auto-detected storage device to Uninstall from, it would preform the operation, and then dump the user back to an Install prompt all without reboot.

Comment 10 Mike Burns 2011-10-31 23:22:44 UTC
What is the use case for uninstall?

The case you described can be handled by using the "Reinstall" option in the Boot Menu.  If you want to install a new version, then you need to boot from media anyway.

Comment 11 Bryan Yount 2011-11-01 16:28:36 UTC
Reinstall doesn't seem to remove everything. For example, I chose reinstall and it still had my NIC devices configured how I had them before. Perhaps that was a beta 2 bug that is now fixed in beta 3; I haven't tried it yet.

Comment 12 Zac Dover 2011-12-06 08:05:42 UTC
Where does this BZ stand as of 6 Dec 2011?

Is it possible to do a clean install from the boot menu?

If you're interested, you should know that BZ#747102 is related to this bug. Upgrading from beta to GA RHEV causes the host to be incorrectly partitioned.

Is this fixed in Beta 3? In order to be fixed in Beta 3, I reckon 1) the boot menu should include an option for a clean install, and 2) NIC devices should not be configured the way they were before the clean install (see Bryan Yount's Comment 11).

Cheers!

Comment 13 Mike Burns 2011-12-06 12:42:04 UTC
The Reinstall option in the boot menu does the cleanup as expected.  This bug is fixed and verified and will ship when the errata ships.

Comment 14 errata-xmlrpc 2011-12-06 19:26:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html

Comment 15 Zac Dover 2011-12-14 08:43:20 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, Red Hat Enterprise Virtualization did not have a boot menu option that provided a clean install. In some cases, attempting a clean install could lead to NIC devices being improperly configured.

Red Hat Enterprise Virtualization now has a boot menu option which provides a clean install which properly configures NIC devices.


Note You need to log in before you can comment on or make changes to this bug.