Bug 73338 - /etc/init.d/sshd generates hostkeys for protocols not in use
/etc/init.d/sshd generates hostkeys for protocols not in use
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
1
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 02:46 EDT by Petri T. Koistinen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 07:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petri T. Koistinen 2002-09-03 02:46:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-12.5 i686; Nav)

Description of problem:
$ sudo grep Protocol /etc/ssh/sshd_config
Protocol 1
$ sudo rm /etc/ssh/ssh_host_*
$ sudo /etc/init.d/sshd restart
Stopping sshd:                                             [  OK  ]
Generating SSH1 RSA host key:                              [  OK  ]
Generating SSH2 RSA host key:                              [  OK  ]
Generating SSH2 DSA host key:                              [  OK  ]
Starting sshd:                                             [  OK  ]
$ sudo pico /etc/ssh/sshd_config
$ sudo grep Protocol /etc/ssh/sshd_config
Protocol 2
$ sudo rm /etc/ssh/ssh_host_*
$ sudo /etc/init.d/sshd restart
Stopping sshd:                                             [  OK  ]
Generating SSH1 RSA host key:                              [  OK  ]
Generating SSH2 RSA host key:                              [  OK  ]
Generating SSH2 DSA host key:                              [  OK  ]
Starting sshd:                                             [  OK  ]
$



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start sshd

	

Actual Results:  Script /etc/init.d/sshd generates hostkeys for protocols not in
use.

Expected Results:  Script /etc/init.d/sshd should not generate hostkeys for
protocols not in use.

Additional info:
Comment 1 Hunter Monroe 2003-07-16 16:48:44 EDT
I have two points on this, having spent six hours finding out why automatic 
ssh logins were not accepted (essential for developers using ssh to connect to 
CVS):

1. The lines for HostKeys for rsa and dsa in sshd_config should not be 
commented out as a default.

2. Whatever choice is made on 1, it should be explained in the documentation--
which now refers to the host keys, but does not say they are disabled by 
default.
Comment 2 Tomas Mraz 2005-02-07 07:49:28 EST
The comment #1 seems to be a completely separate bug.

This bug is WONTFIX as it doesn't seem to be worth the hassle.

Note You need to log in before you can comment on or make changes to this bug.