Bug 733384 - sysconfig core dump with bad scheme parmeter
Summary: sysconfig core dump with bad scheme parmeter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Adam Stokes
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-25 15:27 UTC by Dave Johnson
Modified: 2011-12-06 11:40 UTC (History)
3 users (show)

Fixed In Version: matahari-0.4.3-1.el6
Doc Type: Bug Fix
Doc Text:
No description required
Clone Of:
Environment:
Last Closed: 2011-12-06 11:40:21 UTC


Attachments (Terms of Use)
compressed core file (400.94 KB, application/x-gzip)
2011-08-25 17:51 UTC, Dave Johnson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-25 15:27:04 UTC
Description of problem:
=================================
call the run_uri method (and I am assuming run_string) with a bad schema name and the agent segfaults

    call 1 run_uri http://127.0.0.1/site.pp 0 pupp bad_name

Version-Release number of selected component (if applicable):
==================================================================
v0.4.2-9

How reproducible:
=================================
100%

Steps to Reproduce:
=================================
1.  install puppet
2.  install/start matahari broker & sysconfig agent
3.  with qmf-tool, something like "call 1 run_uri http://127.0.0.1/site.pp 0 pupp bad_name"


Additional info:
=================================
#8  0x0000003b0a69cf33 in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string(char const*, std::allocator<char> const&) () from /usr/lib64/libstdc++.so.6
No symbol table info available.
#9  0x0000003b0d60a892 in qpid::types::Variant::Variant(char const*) () from /usr/lib64/libqpidtypes.so.1
No symbol table info available.
#10 0x0000000000402ef2 in ConfigAgent::invoke (this=<value optimized out>, session=..., event=..., user_data=<value optimized out>)
    at /usr/src/debug/matahari-matahari-325f740/src/sysconfig/sysconfig-qmf.cpp:96
        status = 0x0
        methodName = <value optimized out>
        args = <value optimized out>
#11 0x0000003b13404791 in mh_qpid_callback (session=..., event=<value optimized out>, user_data=0x7fff6482cac0) at /usr/src/debug/matahari-matahari-325f740/src/lib/mh_agent.cpp:128
        agent = 0x7fff6482cac0
        __FUNCTION__ = "mh_qpid_callback"
#12 0x0000003b13404541 in mainloop_qmf_dispatch (source=0x15da200, callback=<value optimized out>, userdata=<value optimized out>) at /usr/src/debug/matahari-matahari-325f740/src/lib/mh_agent.cpp:581
        event = {<qmf::Handle<qmf::AgentEventImpl>> = {impl = 0x7f86a8002df0}, <No data fields>}
        qmf = 0x15da200
        __FUNCTION__ = "mainloop_qmf_dispatch"
#13 0x0000003b09a38f0e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
No symbol table info available.
#14 0x0000003b09a3c938 in ?? () from /lib64/libglib-2.0.so.0
No symbol table info available.
#15 0x0000003b09a3cd55 in g_main_loop_run () from /lib64/libglib-2.0.so.0
No symbol table info available.
#16 0x00000000004028f5 in main (argc=2, argv=<value optimized out>) at /usr/src/debug/matahari-matahari-325f740/src/sysconfig/sysconfig-qmf.cpp:59
        agent = {<MatahariAgent> = {_vptr.MatahariAgent = 0x4065b0, _impl = 0x15ccb80}, _package = {data_Sysconfig = {<qmf::Handle<qmf::SchemaImpl>> = {impl = 0x15d3f30}, <No data fields>}}, _instance = 
    {<qmf::Handle<qmf::DataImpl>> = {impl = 0x15d9ba0}, <No data fields>}, static SYSCONFIG_NAME = "Sysconfig"}
        rc = 0
(gdb)

Comment 2 Dave Johnson 2011-08-25 17:51:05 UTC
Created attachment 519944 [details]
compressed core file

Ok, slightly confused on this after I did another recreate for the core file.  Below you can see that I am passing in a bad schema and it is returning ok (which is bad but no core file).   But then I passed in my original values that generated the core file and it happened.  Hopefully the core file will make sense out of it

qmf: call 5 run_uri http://127.0.0.1/site.pp 0 puppe site_http
Output Parameters:
    Name    Value
    ===============
    status  OK
qmf: call 5 run_uri http://127.0.0.1/site.pp 0 puppe site_http
Output Parameters:
    Name    Value
    ===============
    status  OK
qmf: call 5 run_uri http://127.0.0.1/site.pp 0 pupp site_http
Output Parameters:
    Name    Value
    ===============
    status  OK
qmf: call 5 run_uri http://127.0.0.1/site.pp 0 pup site_http
Output Parameters:
    Name    Value
    ===============
    status  OK
qmf: call 5 run_uri http://127.0.0.1/site.pp 0 pupp bad_name
Exception in call command: From Remote Agent: {'error_text': 'Timed out waiting for the agent to respond'}
qmf:

Comment 5 Dave Johnson 2011-09-09 18:27:19 UTC
good 2 go in v0.4.4-2

Comment 6 Russell Bryant 2011-11-16 21:54:33 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required

Comment 7 errata-xmlrpc 2011-12-06 11:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.