Bug 73340 - i810_audio sound corruption
i810_audio sound corruption
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 04:21 EDT by Didier
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 15:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Didier 2002-09-03 04:21:59 EDT
Description of Problem:

When playing any random sound sample, speakers output noise.


Version-Release number of selected component (if applicable):

2.4.18-12.2
2.4.18-12.5

How Reproducible:

approx. 7 out of 10


Steps to Reproduce:
1. induce audio output (XMMS, Gnome events, ...)
 

Actual Results:

Scrambled sound


Expected Results:

Comprehensible sound


Additional Information:

Fine with Limbo2, problems started with (null)

/var/log/messages :


Sep  1 11:58:36 localhost kernel: i810_audio: DMA overrun on write
Sep  1 11:58:36 localhost kernel: i810_audio: CIV 0, LVI 19, hwptr 96a, count -27778
Sep  1 11:58:36 localhost kernel: i810_audio: DMA overrun on write
Sep  1 11:58:36 localhost kernel: i810_audio: CIV 0, LVI 19, hwptr b72, count -8
Sep  1 11:58:36 localhost kernel: i810_audio: DMA overrun on write
Sep  1 11:58:36 localhost kernel: i810_audio: CIV 0, LVI 19, hwptr dda, count -104
Comment 1 Didier 2002-09-03 05:12:58 EDT
Additional info : IBM ThinkPad A30p (2653)

#lsmod

i810_audio             25160   1  (autoclean)
ac97_codec             13320   0  (autoclean) [i810_audio]
soundcore               6500   2  (autoclean) [i810_audio]


#lspci -v

00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio (rev 01)
        Subsystem: IBM IBM ThinkPad T23 (2647-4MG)
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at 1c00 [size=256]
        I/O ports at 18c0 [size=64]

As you notice, lspci incorrectly identifies the subsystem as a T23 instead of an
A30p.

Comment 2 Ray Parish 2002-09-03 14:19:13 EDT
Actually this only happens on the 2.4.18-12x kernels.
If I run the 2.4.18-11 everything is fine again.
Comment 3 Didier 2002-09-04 14:29:27 EDT
Confirmed : audio functionality is restored by reverting to 2.4.18-11.
Comment 4 Didier 2002-09-05 15:39:53 EDT
Seems to be corrected with 2.4.18-14.

Note You need to log in before you can comment on or make changes to this bug.