This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 73341 - no includes XLFD for Korean
Summary: no includes XLFD for Korean
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ttfonts-ko (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Joo
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-03 08:38 UTC by Akira TAGOH
Modified: 2007-04-18 16:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 01:01:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ttmkfdir-default-encodings.dir-patch.diff (737 bytes, patch)
2002-09-04 08:13 UTC, Yu Shao
no flags Details | Diff

Description Akira TAGOH 2002-09-03 08:38:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
/usr/share/fonts/ko/TrueType/fonts.dir has no valid entries for ko_KR.eucKR.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.looks at /usr/share/fonts/ko/TrueType/fonts.dir
2.
3.
	

Actual Results:  fonts.dir contains only ascii-0 and iso10646-1.

Expected Results:  fonts.dir should contains ksc5601.1987-0 at least.

Additional info:

Comment 1 Leon Ho 2002-09-03 14:03:24 UTC
From fresh installation or upgrade? Upgrade usually will run ttmkfdir from xfs initscript 
because there must be some files newer than fonts.dir, which it breaks the fonts.dir. 
 
I saw the changelog that Mike has disabled the premade fonts.scale previously. How does 
premade fonts.scale breaks?

Comment 2 Akira TAGOH 2002-09-04 07:03:36 UTC
fresh installataion. ttfonts-ko generates even fonts.scale on %%post. I'm sure
ttmkfdir has a problem at least.

Comment 3 Leon Ho 2002-09-04 07:44:32 UTC
If you really want to generate fonts.scale from ttmkfdir instead of the premade one 
(which  
IMHO is better because we can get rid of some unused charsets), the sane way to do is  
modify ttfonts-ko and xfs initscript to use "ttmkfdir -e  
/usr/X11R6/lib/X11/fonts/encodings/encodings.dir" to get the encodings directories from  
there. By default right now ttmkfdir only searchs encodings.dir in the currect directory.  


Comment 4 Yu Shao 2002-09-04 08:08:46 UTC
Hi Mike, can we use this patch, it just set ttmkfdir's default encodings.dir as
the system default.

Comment 5 Yu Shao 2002-09-04 08:13:23 UTC
Created attachment 74844 [details]
ttmkfdir-default-encodings.dir-patch.diff

Comment 8 Mike A. Harris 2002-10-07 06:22:35 UTC
Me and David Joo are investigating this...

Comment 9 Leon Ho 2003-01-21 01:01:56 UTC
fixed on latest ttmkfdir 


Note You need to log in before you can comment on or make changes to this bug.