Bug 733410 - [abrt] ghostscript-8.71-16.fc14: gx_device_finalize: Process /usr/bin/gs was killed by signal 11 (SIGSEGV)
Summary: [abrt] ghostscript-8.71-16.fc14: gx_device_finalize: Process /usr/bin/gs was ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d996c113d309012c154f5d51c2d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 16:14 UTC by Hrvoje Bratanić
Modified: 2012-02-06 14:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-06 14:32:55 UTC


Attachments (Terms of Use)
File: backtrace (172.02 KB, text/plain)
2011-08-25 16:14 UTC, Hrvoje Bratanić
no flags Details
The actual PDF document that caused the crash. I was able to reproduce the crash and am probably still able. (11.53 MB, application/x-7z-compressed)
2011-08-25 17:11 UTC, Hrvoje Bratanić
no flags Details

Description Hrvoje Bratanić 2011-08-25 16:14:43 UTC
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 176151 bytes
cmdline: gs DIR-600_B2_Manual_v3.00(E).pdf
component: ghostscript
Attached file: coredump, 21254144 bytes
crash_function: gx_device_finalize
executable: /usr/bin/gs
kernel: 2.6.35.14-95.fc14.i686
package: ghostscript-8.71-16.fc14
rating: 4
reason: Process /usr/bin/gs was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1314288953
uid: 500

How to reproduce
-----
1. Open the file 'DIR-600_B2_Manual_v3.00(E).pdf' from a terminal window. The file is a rather ordinary PDF document with pictures and text. Command is 'gs DIR-600_B2_Manual_v3.00(E).pdf'.
2. Move focus to ghost script windows which has opened.
3. Press 'Enter' while tocus is on ghost script window.
4. Move focus back to terminal and press 'Enter' repeatedly.

Comment 1 Hrvoje Bratanić 2011-08-25 16:14:50 UTC
Created attachment 519920 [details]
File: backtrace

Comment 2 Tim Waugh 2011-08-25 16:41:42 UTC
Are you able to attach the PDF file to this bug report?

Comment 3 Hrvoje Bratanić 2011-08-25 17:11:20 UTC
Created attachment 519936 [details]
The actual PDF document that caused the crash. I was able to reproduce the crash and am probably still able.

Comment 4 Tim Waugh 2011-08-30 10:45:58 UTC
Thanks.

Reproduced with: ghostscript-8.71-16.fc14.x86_64
Cannot reproduce with ghostscript-9.04-2.fc15.x86_64

gs -dNOPAUSE DIR--600_B2_Manual_v3.00(E).pdf

Crashes on page 4 in Fedora 14.

Comment 6 Tim Waugh 2011-09-02 14:53:43 UTC
I haven't been able to narrow down what's causing this, or why it works in newer versions of ghostscript.


Note You need to log in before you can comment on or make changes to this bug.