Bug 733456 - analyze_smolt exit 1.
Summary: analyze_smolt exit 1.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 16
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Denys Vlasenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 18:19 UTC by solanum
Modified: 2011-09-30 17:17 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-30 17:17:42 UTC


Attachments (Terms of Use)

Description solanum 2011-08-25 18:19:06 UTC
Description of problem:
running a bug report using abrt, on an x64 cpu sandy-bridge efi, i ran the backtraces through abrt followed the steps, and then smolt tried to get the hardwareprofile and it just says "smolt_analyze" exit 1. Then you cant submit to bugzilla without saving a local copy. 

This is 16 alpha with most of the non-gnome patches installed. except it has the old kernel (since the new one isnt working right. 


(this is probably a duplicate of something. I didn't look -that- hard for it. )

Comment 1 Nikola Pajkovsky 2011-09-05 10:57:33 UTC
Which version of abrt/libreport do you use? Do you have installed smolt?

Comment 2 solanum 2011-09-06 20:15:55 UTC
It was whatever was installed by default with a graphical user environment with an update prior to submission. I should have recorded it in the problem. 

The machine has be reinstalled with the addition of the Development Tools, and Virtualization and updated. 

Currently the machine has: 
[so@oinik ~]$ rpm -qa |grep smolt
smolt-firstboot-1.4.3-5.fc16.noarch
smolt-1.4.3-5.fc16.noarch
[so@oinik ~]$ rpm -qa |grep abrt
abrt-desktop-2.0.4-2.fc16.x86_64
abrt-addon-python-2.0.4-2.fc16.x86_64
abrt-addon-kerneloops-2.0.4-2.fc16.x86_64
abrt-addon-ccpp-2.0.4-2.fc16.x86_64
abrt-libs-2.0.4-2.fc16.x86_64
abrt-2.0.4-2.fc16.x86_64
abrt-gui-2.0.4-2.fc16.x86_64
[so@oinik ~]$

Comment 3 Denys Vlasenko 2011-09-21 16:17:23 UTC
Corresponding code from current git:

EVENT=collect_Smolt
        which smoltSendProfile >/dev/null 2>&1 || {
            echo "Smolt package not installed, can't save profile"
            exit 0
        }
        smoltSendProfile -p >smolt_data 2>&1 || exit $?
        echo "Smolt profile successfully saved"

It looks correct to me:
The only way it can exit with !0 is if "smoltSendProfile -p" fails.

Comment 4 Denys Vlasenko 2011-09-30 17:17:42 UTC
Closing as WORKSFORME.

Reopen if you have a reproducer.


Note You need to log in before you can comment on or make changes to this bug.