Bug 733483 - windows agents fail to connect to broker
Summary: windows agents fail to connect to broker
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Adam Stokes
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-25 19:21 UTC by Dave Johnson
Modified: 2011-12-06 11:40 UTC (History)
2 users (show)

Fixed In Version: matahari-0.4.4-1.el6
Doc Type: Bug Fix
Doc Text:
No description required.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:40:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-25 19:21:27 UTC
Description of problem:
==============================
Summary says it all.  If I install mingw32-matahari, install it's iso image on a windows box, configure the broker IP in the registry, and restart the agents, they fail to show up as connected to the broker whether using python or qmf-tool.

I ran a tcpdump session and can see the packets coming across the wire but for what ever reason, it is not connecting (AND doesn't appear to attempt any reconnects).

I tried enabling debug messaging on the windows side but could get it to work.

Version-Release number of selected component (if applicable):
==============================================================
mingw32-matahari-0.4.2-9

How reproducible:
=====================================
100%

Steps to Reproduce:
=====================================
1.  install/start matahari-broker
2.  install mingw32-matahari
3.  grab iso from mingw32-matahari
4.  copy/install iso on windows box
5.  configure broker ip through registry key
6.  restart agents
7.  on broker, 'qmf-tool localhost:49000'
8.  list agents, nothing connected
  
I have access to windows vm's if you need them...

Comment 2 Dave Johnson 2011-08-26 19:18:20 UTC
I was able to enable debug logging using v0.4.0-5 by adding the 'verbose' registry string value.  Attempting to run the agents in debug from the windows command line using v0.4.2-9 they all crash with the following error details.

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	matahari-qmf-hostd.exe
  Application Version:	0.0.0.0
  Application Timestamp:	4e554264
  Fault Module Name:	libqpidtypes.dll
  Fault Module Version:	0.0.0.0
  Fault Module Timestamp:	4d91ea90
  Exception Code:	40000015
  Exception Offset:	00022f8f
  OS Version:	6.1.7600.2.0.0.272.7
  Locale ID:	1033
  Additional Information 1:	979f
  Additional Information 2:	979fce893fa19c859a9d93203f719072
  Additional Information 3:	03d1
  Additional Information 4:	03d11bf9ca35c5cee60c0340d35c1c9f

Comment 3 Adam Stokes 2011-09-06 13:24:36 UTC
This problem occurs because returning NULL from mh_uuid() is not an acceptable type within qpid.

There is no Windows variant for gathering/creating UUID a patch is in process which the thread can be found :

https://fedorahosted.org/pipermail/matahari/2011-September/001795.html

Comment 7 Dave Johnson 2011-09-09 21:56:27 UTC
good 2 go in v0.4.4-2

Comment 8 Russell Bryant 2011-11-16 21:59:12 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required.

Comment 9 errata-xmlrpc 2011-12-06 11:40:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.