Bug 733578 - Failed to install rhevh via TUI if the disk have RHEL installed
Summary: Failed to install rhevh via TUI if the disk have RHEL installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 05:26 UTC by Guohua Ouyang
Modified: 2011-12-06 19:26 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-2.0.2-0.3.gitcf213a7.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:26:50 UTC


Attachments (Terms of Use)
ovirt.log (115.13 KB, text/plain)
2011-08-26 05:26 UTC, Guohua Ouyang
no flags Details
Patch (2.29 KB, patch)
2011-08-31 23:23 UTC, Mike Burns
no flags Details | Diff
fix install when VG exists on disk (4.06 KB, patch)
2011-09-02 01:52 UTC, Alan Pevec
no flags Details | Diff
fix install when VG exists on disk (4.51 KB, patch)
2011-09-02 20:23 UTC, Alan Pevec
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Guohua Ouyang 2011-08-26 05:26:32 UTC
Created attachment 520005 [details]
ovirt.log

Description of problem:
The disk have RHEL installed on, then install rhevh on the same disk via TUI is failed.  But autoinstall have no this problem.

#tail ovirt.log:
Successfully persisted: /etc/shadow
installing the image.
Unable to find Root partition
Root
_rhev-hypervisor
RootBackup
rhev-hypervisor
/dev/loop0: LABEL="rhev-hypervisor" TYPE="iso9660" 
/dev/loop1: TYPE="squashfs" 
/dev/loop3: TYPE="squashfs" 
/dev/loop4: LABEL="_rhev-hypervisor" UUID="358c2062-7880-47de-be6e-9718c2a2682a" TYPE="ext2" 
/dev/loop5: TYPE="DM_snapshot_cow" 
/dev/loop6: LABEL="_rhev-hypervisor" UUID="358c2062-7880-47de-be6e-9718c2a2682a" TYPE="ext2" 
/dev/mapper/HostVG-Swap: LABEL="SWAP" UUID="940a2071-1280-40da-b41c-2dfe4104f24d" TYPE="swap" 
/dev/mapper/HostVG-Config: LABEL="CONFIG" UUID="807494c9-b39e-43da-8ccc-f4dec3864735" TYPE="ext4" 
/dev/mapper/HostVG-Logging: LABEL="LOGGING" UUID="d34c7789-01b5-4046-ace4-ed1810733141" TYPE="ext4" 
/dev/mapper/HostVG-Data: LABEL="DATA" UUID="2ea6bef3-5aa5-4e83-a17c-55b37365dcb7" TYPE="ext4" 
/dev/mapper/1ATA     WDC WD3200AAKS-75L9A0                        WD-WMAV27854193p3: UUID="Eyh56V-aVGm-9yJa-16PL-3CKU-463O-TKduBL" TYPE="LVM2_member" 
/dev/mapper/1ATA     WDC WD3200AAKS-75L9A0                        WD-WMAV27854193p1: LABEL="Root" UUID="63e0a9d3-2e7f-44f0-949a-086b281f7418" TYPE="ext2" 


Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.14

How reproducible:
100%.

Steps to reproduce:
1. Install RHEL6 on local disk.
- while install RHEL6 were using entire disk and choose minimum mode to install.
2. Install rhevh on local disk via TUI.

Actual results:
Install failed.

Expected results:
install successful. 

Additional info:
It only happened on TUI, autoinstall via PXE with params: storage_init=ata local_boot firstboot have no this issue.

Comment 2 Guohua Ouyang 2011-08-26 06:37:21 UTC
Tested another scenario:
1. install win2k8 in VM first.
2. install rhevh-6.2-0.14 in VM on the same disk.
result: install is successful and boot into rhevh is ok.

Comment 3 Mike Burns 2011-08-31 13:11:35 UTC
I've reproduced this with a virtio disk in a vm.  I looked into why it's happening and found a couple things:

in storage.py:

wipe_lvm_on_disk:

pvscan -o ...  there is no -o option for pvscan, should be pvs
with this setup, we end up calling wipe_volume_group with the vg uuid, not the vg name.  AFAICT, this doesn't work for wipe_volume_group.

Something like this is needed:

vg_name = system("vgs -o vg_name,vg_uuid --noheadings 2>/dev/null | grep -w \"" + vg + "\" | awk '{print $1}'")

I also found that running vgchange -an $vg_name will allow the system to install, but has issues after reboot.

Comment 4 Mike Burns 2011-08-31 23:19:52 UTC
reboot issues are unrelated to this bug.

Comment 5 Mike Burns 2011-08-31 23:23:05 UTC
Created attachment 520922 [details]
Patch

Comment 6 Alan Pevec 2011-09-02 01:52:56 UTC
Created attachment 521126 [details]
fix install when VG exists on disk

Comment 7 Alan Pevec 2011-09-02 20:23:28 UTC
Created attachment 521280 [details]
fix install when VG exists on disk

Comment 9 Guohua Ouyang 2011-09-06 10:19:03 UTC
Verified on 6.2-0.15:
1. the disk have RHEL installed, install rhevh via tui successfully.
2. the disk have RHEL installed, autoinstall rhevh successfully.

Comment 10 errata-xmlrpc 2011-12-06 19:26:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.